mesos-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Omernik <j...@omernik.com>
Subject Re: Weird Error on One Node
Date Fri, 04 Dec 2015 19:58:55 GMT
I tried restarting the slave again and this time it worked... *shrug*

That said, anything I can do next time this happens?  Do I need to do
something on RHEL7 and Cgroups to make the info in MESOS-3352 work?

Thanks!

John

On Fri, Dec 4, 2015 at 1:54 PM, John Omernik <john@omernik.com> wrote:

> I am trying to start a task on a node, and it keeps failing with no logs
> in the sandbox (it's blank)
>
>
> In the slave logs, I get the error below.  I looked into MESOS-3352 and
> since I am running RHEL 7 with Version 208 (that "should" be the patched
> version based on what I've read). I am thinking this should be working. (I
> am running Mesos 0.25.0) Now, that warning and my issue may not be related
> as that warning may pop up anytime it detects systemd < 218.
>
> That said, I tried stopping the slave, clearning all files for the slave
> and restarting, and can't seem to get it to work (clearning all files is
> erasing logs and tmp folders).
>
>
> There are not that many available logs, so any help would be appreciated.
>
> John
>
>
>
>
> W1204 19:40:47.767102 21241 systemd.cpp:136] Required functionality
> `Delegate` was introduced in Version `218`. Your system may not function
> properly; however since some distributions have patched systemd packages,
> your system may still be functional. This is why we keep running. See
> MESOS-3352 for more information
>
> W1204 19:43:45.861021 21254 slave.cpp:2141] Ignoring updating pid for
> framework 9fb66f25-2a80-44be-857b-a51de754618c-0000 because it does not
> exist
>
> E1204 19:47:07.500804 21265 slave.cpp:3342] Container
> '1500d513-fb13-484e-a9a9-3c9c70a66be6' for executor
> 'zetadrill.ccedde4d-9abf-11e5-b92d-024209d8b836' of framework
> '9fb66f25-2a80-44be-857b-a51de754618c-0000' failed to start: Failed to
> prepare isolator: Failed to create directory
> '/sys/fs/cgroup/memory/mesos/1500d513-fb13-484e-a9a9-3c9c70a66be6': No such
> file or directory
>

Mime
View raw message