mesos-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Pradeep Kiruvale <pradeepkiruv...@gmail.com>
Subject Re: Executor can't start d-bus communication
Date Wed, 14 Oct 2015 15:24:58 GMT
Hi Greg,

 I solved the issue. The problem was with credentials. I was running Master
and Slave as root and Framework as normal user.

 After I started all components as user, its worked.

I wrote the executor using the Executor APIs. By creating a new class.

Thanks for your reply.

Regards,
Pradeep


On 14 October 2015 at 17:18, Greg Mann <greg@mesosphere.io> wrote:

> Hi Pradeep,
> Can you tell us a bit about your executor: in particular, did you write it
> against the Executor API
> <http://mesos.apache.org/documentation/latest/app-framework-development-guide/>,
> or is it a plain executable that gets run through the command executor?
>
> Cheers,
> Greg
>
> On Wed, Oct 14, 2015 at 1:26 AM, Pradeep Kiruvale <
> pradeepkiruvale@gmail.com> wrote:
>
>> Hi All,
>>
>> I have written a new framework and an executor. I launch the task from
>> Framework and the task get pushed to the specific slave/executor based on
>> the resource availability. But on the executor side it has to connect to an
>> application which is running and providing the service through the d-bus
>> interface. But the executor fails to connect to the application through the
>> d-bus interfaces.
>>
>> But if I launch the d-bus connection from a standalone application it
>> works fine. But I cant connect from executor.
>>
>> Any idea how can I fix this?
>>
>> Thanks & Regards,
>> Pradeep
>>
>>
>

Mime
View raw message