mesos-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Rojas <alexan...@mesosphere.io>
Subject Re: OS X build
Date Mon, 05 Oct 2015 09:16:08 GMT
Well, libapr-1 is supposed to be shipped with default with OS X, so in theory one shouldn’t
need to use the homebrew version. I did had a problem with my machine not finding libapr after
I updated to “El Capitan.” My solution was to reinstall the command line tools with `code-select
—install`. Note that with the latest OS X you may need to set:

```
export CXXFLAGS="-Wno-unused-local-typedef -Wno-deprecated-declarations”
export CCFLAGS="-Wno-unused-local-typedef -Wno-deprecated-declarations”
```

Since the latest OS X deprecates libsasl.


> On 26 Sep 2015, at 21:01, Vaibhav Khanduja <vaibhavkhanduja@gmail.com> wrote:
> 
> I am running into issues with build on my MAC - OSX … the configure scripts complaints
about libapr-1 not present. I was able to find a workaround by passing configure with —with-apr
option. Looks like the script checks for variable to be valid shell variable, if not it is
rejected.
> 
> I was able workaround with having quotes and missing a “-“ for the variable
> 
>  ../configure -disable-python --disable-java "-with-apr=/usr/local/Cellar/apr/1.5.2/libexec/“
> 
> the configure —help though suggests to use —with-apr 
> 
> am I missing something here?
> 
> Thx


Mime
View raw message