mesos-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bilna Govind <biln...@gmail.com>
Subject mesos-0.18.1 make gives heap error
Date Thu, 18 Sep 2014 07:37:59 GMT
Hi,

I would like to run spark 1.0 on mesos. I read in spark website's
deployment-help-page that spark 1.0 is designed for mesos 0.18.1. so i
tried to build mesos-0.18.1.
I tried as per the instruction in http://mesos.apache.org/gettingstarted/

../configure => executed successfully

make => gives the following error

Loading source files for package org.apache.mesos.state...
Loading source files for package org.apache.mesos...
289142 errors
[ERROR] Java heap space -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the -e
switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/OutOfMemoryError
make[1]: *** [java/target/mesos-0.18.1.jar] Error 1
make[1]: Leaving directory `/home/username/mesos-0.18.1/build/src'
make: *** [all-recursive] Error 1

I have given MAVEN_OPTS as -Xms1024m -Xmx4096m -XX:PermSize=1024m

what should I do to resolve this issue. If any one has a solution to this
problem please  share it

-- 
Regards,
Bilna P

Mime
View raw message