mesos-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Benjamin Mahler <benjamin.mah...@gmail.com>
Subject Re: Compiling Mesos on Mac OSX Mountain Lion 10.9
Date Thu, 30 Jan 2014 19:46:07 GMT
I don't believe that we compile with C++11 on gcc 4.2, and C++11 support
did not land in 0.16.0 IIRC.

You should remove your -std=c++11 flag. Let us know if that does not work.


On Thu, Jan 30, 2014 at 11:40 AM, Tom Arnfeld <tom@duedil.com> wrote:

> I'm trying to get going with Mesos to do a bit of exploration and i'm
> having trouble compiling any version of Mesos on Mac OSX. I'm only looking
> to use the python binding (not actually run a mesos master/slave) on OSX to
> talk to a remote Mesos/ZK cluster i've got setup.
>
> I've sifted through a bunch of errors, and hit a wall with one I can't
> seem to solve. I'm using GCC 4.2 (`brew install gcc4.2`) as there are
> issues with the GCC included in Xcode. I've also had to switch to using
> protobuf 2.5.0 in `mesos/3rdparty/libprocess/3rdparty.
>
> > git clone https://git-wip-us.apache.org/repos/asf/mesos.git
> > cd mesos
> > git checkout git checkout 0.16.0-rc4
> > ./bootstrap
> > CC="gcc-4.2" CXXFLAGS="-std=c++11" ./configure
> > make
>
> ########################################################################
>
> /bin/sh ./libtool  --tag=CXX   --mode=compile g++
> -DPACKAGE_NAME=\"libprocess\" -DPACKAGE_TARNAME=\"libprocess\"
> -DPACKAGE_VERSION=\"0.0.1\" -DPACKAGE_STRING=\"libprocess\ 0.0.1\"
> -DPACKAGE_BUGREPORT=\"\" -DPACKAGE_URL=\"\" -DPACKAGE=\"libprocess\"
> -DVERSION=\"0.0.1\" -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1
> -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1 -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1
> -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1
> -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\" -DHAVE_PTHREAD=1 -DHAVE_LIBZ=1 -I.
>  -I./include -I./3rdparty/stout/include -I3rdparty/boost-1.53.0
> -I3rdparty/glog-0.3.3/src -I3rdparty/libev-4.15
> -I3rdparty/ry-http-parser-1c3624a     -std=c++11 -g2 -O2 -MT
> libprocess_la-latch.lo -MD -MP -MF .deps/libprocess_la-latch.Tpo -c -o
> libprocess_la-latch.lo `test -f 'src/latch.cpp' || echo './'`src/latch.cpp
> libtool: compile:  g++ -DPACKAGE_NAME=\"libprocess\"
> -DPACKAGE_TARNAME=\"libprocess\" -DPACKAGE_VERSION=\"0.0.1\"
> "-DPACKAGE_STRING=\"libprocess 0.0.1\"" -DPACKAGE_BUGREPORT=\"\"
> -DPACKAGE_URL=\"\" -DPACKAGE=\"libprocess\" -DVERSION=\"0.0.1\"
> -DSTDC_HEADERS=1 -DHAVE_SYS_TYPES_H=1 -DHAVE_SYS_STAT_H=1 -DHAVE_STDLIB_H=1
> -DHAVE_STRING_H=1 -DHAVE_MEMORY_H=1 -DHAVE_STRINGS_H=1 -DHAVE_INTTYPES_H=1
> -DHAVE_STDINT_H=1 -DHAVE_UNISTD_H=1 -DHAVE_DLFCN_H=1 -DLT_OBJDIR=\".libs/\"
> -DHAVE_PTHREAD=1 -DHAVE_LIBZ=1 -I. -I./include -I./3rdparty/stout/include
> -I3rdparty/boost-1.53.0 -I3rdparty/glog-0.3.3/src -I3rdparty/libev-4.15
> -I3rdparty/ry-http-parser-1c3624a -std=c++11 -g2 -O2 -MT
> libprocess_la-latch.lo -MD -MP -MF .deps/libprocess_la-latch.Tpo -c
> src/latch.cpp  -fno-common -DPIC -o libprocess_la-latch.o
> In file included from src/latch.cpp:3:
>
> ./include/process/process.hpp:10:10: fatal error: 'tr1/functional' file
> not found
> #include <tr1/functional>
>          ^
> 1 error generated.
>
> ####################################
>
> The call to `make` fails with the above output. I managed to successfully
> install thrift version 0.9.1using brew (though unrelated) which makes me
> think it might not be an issue with thrift, but with the mesos build
> process?
>
> I can attach my Makefile if that's of any help, Thanks.
>
> --
> Tom Arnfeld
> Developer // DueDil
>

Mime
View raw message