mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Mann <g...@mesosphere.io>
Subject Re: Review Request 65000: Added an SLRP test for agent being registered with a new ID.
Date Thu, 25 Jan 2018 19:09:22 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/65000/#review196274
-----------------------------------------------------------


Fix it, then Ship it!





src/tests/storage_local_resource_provider_tests.cpp
Lines 1046-1054 (patched)
<https://reviews.apache.org/r/65000/#comment275827>

    Could you place these declarations directly above the sites where they are used?



src/tests/storage_local_resource_provider_tests.cpp
Lines 1110 (patched)
<https://reviews.apache.org/r/65000/#comment275828>

    Can this line be eliminated?



src/tests/storage_local_resource_provider_tests.cpp
Lines 1137 (patched)
<https://reviews.apache.org/r/65000/#comment275829>

    Instead of `volume1` and `volume2`, could you use more descriptive names? Perhaps `createdVolume`
and `preExistingVolume`?


- Greg Mann


On Jan. 25, 2018, 1:44 a.m., Chun-Hung Hsiao wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/65000/
> -----------------------------------------------------------
> 
> (Updated Jan. 25, 2018, 1:44 a.m.)
> 
> 
> Review request for mesos, Gaston Kleiman, Greg Mann, and Jie Yu.
> 
> 
> Bugs: MESOS-8409
>     https://issues.apache.org/jira/browse/MESOS-8409
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added an SLRP test for agent being registered with a new ID.
> 
> 
> Diffs
> -----
> 
>   src/tests/storage_local_resource_provider_tests.cpp 5ac91802e7c79e769c59c8418502ccc9d41f51b4

> 
> 
> Diff: https://reviews.apache.org/r/65000/diff/3/
> 
> 
> Testing
> -------
> 
> sudo make check
> 
> 
> Thanks,
> 
> Chun-Hung Hsiao
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message