mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Greg Mann <g...@mesosphere.io>
Subject Re: Review Request 60847: Add test cases for /slaves, /slave/containers, /frameworks endpoints.
Date Tue, 18 Jul 2017 20:23:05 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/60847/#review180852
-----------------------------------------------------------




src/tests/master_tests.cpp
Lines 2513 (patched)
<https://reviews.apache.org/r/60847/#comment256147>

    Can remove this comment.



src/tests/master_tests.cpp
Lines 2523-2524 (patched)
<https://reviews.apache.org/r/60847/#comment256146>

    Newline here.



src/tests/master_tests.cpp
Lines 2562 (patched)
<https://reviews.apache.org/r/60847/#comment256148>

    Can remove this comment.



src/tests/master_tests.cpp
Lines 2587 (patched)
<https://reviews.apache.org/r/60847/#comment256149>

    s/recovered_slaves/recovered/



src/tests/master_tests.cpp
Lines 2591 (patched)
<https://reviews.apache.org/r/60847/#comment256150>

    Let's use single quotes for consistency:
    
    'recovered_slaves'



src/tests/master_tests.cpp
Lines 3742-3784 (original), 3863-3896 (patched)
<https://reviews.apache.org/r/60847/#comment256151>

    Could you break this change out into a separate patch?



src/tests/master_tests.cpp
Line 5866 (original), 5980-5981 (patched)
<https://reviews.apache.org/r/60847/#comment256153>

    Newline after this comment.



src/tests/master_tests.cpp
Lines 5985 (patched)
<https://reviews.apache.org/r/60847/#comment256154>

    Let's use `driver` instead of `schedDriver` for these variables. This is more consistent
with the rest of this file.



src/tests/master_tests.cpp
Lines 6019 (patched)
<https://reviews.apache.org/r/60847/#comment256155>

    The word "query" here is ambiguous. How about:
    
    "Request with no query parameter."



src/tests/master_tests.cpp
Lines 6098 (patched)
<https://reviews.apache.org/r/60847/#comment256162>

    s/shutdown call/teardown call/



src/tests/slave_tests.cpp
Lines 2429 (patched)
<https://reviews.apache.org/r/60847/#comment256163>

    How about something more descriptive for this variable name, maybe `launchedTask1`?



src/tests/slave_tests.cpp
Lines 2453-2475 (original), 2610-2657 (patched)
<https://reviews.apache.org/r/60847/#comment256164>

    If we remove the 'executor_id' field from this JSON, can we have just a single `expected`
value, and simply do `EXPECT_TRUE(value->contains(expected.get()));`?


- Greg Mann


On July 18, 2017, 6:28 p.m., Quinn Leng wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/60847/
> -----------------------------------------------------------
> 
> (Updated July 18, 2017, 6:28 p.m.)
> 
> 
> Review request for mesos, Anand Mazumdar, Alexander Rojas, Greg Mann, and Vinod Kone.
> 
> 
> Bugs: MESOS-7630
>     https://issues.apache.org/jira/browse/MESOS-7630
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added query parameter test cases for '/slaves' and '/frameworks' on
> the master, and '/slave/containers' endpoint on the slave.
> 
> 
> Diffs
> -----
> 
>   src/tests/master_tests.cpp 6e6461c2e13c3eb055aa3c2d8ad8e3ac54a1d197 
>   src/tests/slave_tests.cpp 035db18db3a64a9e358c1c54cc18a4bdeb85d8bf 
> 
> 
> Diff: https://reviews.apache.org/r/60847/diff/3/
> 
> 
> Testing
> -------
> 
> Passed 'make check -j48'
> Passed 'GTEST_FILTER="MasterTest.FrameworksEndpointQueryFramework" make check -j48'
> Passed 'GLOG_v=1 ./bin/mesos-tests.sh --gtest_filter="MasterTest.FrameworksEndpointQueryFramework"
--gtest_repeat=1000 --gtest_break_on_failure'
> Passed 'GTEST_FILTER="MasterTest.SlavesEndpointQuerySlave" make check -j48'
> Passed 'GLOG_v=1 ./bin/mesos-tests.sh --gtest_filter="MasterTest.SlavesEndpointQuerySlave"
--gtest_repeat=1000 --gtest_break_on_failure'
> 
> 
> Thanks,
> 
> Quinn Leng
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message