mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Peach <jpe...@apache.org>
Subject Re: Review Request 57816: Add a scheduler flag `offers_suppressed`.
Date Mon, 03 Apr 2017 17:05:23 GMT


> On March 31, 2017, 8:47 p.m., James Peach wrote:
> > src/sched/flags.hpp
> > Lines 127 (patched)
> > <https://reviews.apache.org/r/57816/diff/1/?file=1670987#file1670987line127>
> >
> >     Recommend you rename this to `subscribe_suppressed` or something similar. The
flag is for suppressing offers at subscription time, and I find `offers_suppressed` a bit
too generic and oopen to interpretation.
> 
> Anindya Sinha wrote:
>     Agreed. How about `offers_originally_suppressed` or `offers_suppressed_on_register`?

``offers_suppressed_on_register`` sounds OK to me. Is there anywhere these flags can be documented?


- James


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/57816/#review170767
-----------------------------------------------------------


On March 31, 2017, 8:20 p.m., Anindya Sinha wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/57816/
> -----------------------------------------------------------
> 
> (Updated March 31, 2017, 8:20 p.m.)
> 
> 
> Review request for mesos, James Peach, Vinod Kone, and Jiang Yan Xu.
> 
> 
> Bugs: MESOS-7015
>     https://issues.apache.org/jira/browse/MESOS-7015
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> If the framework sets this flag to indicate that it wants offers
> suppressed on successful registration to master, we pass this
> information to the master in the `SUBSCRIBE` call.
> 
> 
> Diffs
> -----
> 
>   src/sched/flags.hpp d19d20bad7dba48c8792783c73115affa1430cbe 
>   src/sched/sched.cpp ef73c1dccfd736b79f40a057951f022df7f60644 
> 
> 
> Diff: https://reviews.apache.org/r/57816/diff/1/
> 
> 
> Testing
> -------
> 
> All tests passed.
> 
> 
> Thanks,
> 
> Anindya Sinha
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message