mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guangya Liu <gyliu...@gmail.com>
Subject Re: Review Request 50123: Added GPU scheduler for docker containerizer process.
Date Sun, 07 Aug 2016 16:04:30 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/50123/#review145049
-----------------------------------------------------------




src/slave/containerizer/docker.hpp (line 283)
<https://reviews.apache.org/r/50123/#comment211210>

    What about 
    
    ```
    Option<NvidiaGpuAllocator> nvidiaGpuAllocator;
    ```
    
    The reason I want to rename it as this is because we have two allocators now: one is the
built-in drt allocator and the other is nvidia gpu allocator, it is better use a name which
is more meaningful to distinguish with the drf allocator.
    
    Ditto for other places where is using `allocator`.


- Guangya Liu


On 八月 5, 2016, 9:47 a.m., Yubo Li wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/50123/
> -----------------------------------------------------------
> 
> (Updated 八月 5, 2016, 9:47 a.m.)
> 
> 
> Review request for mesos, Benjamin Mahler, Kevin Klues, and Rajat Phull.
> 
> 
> Bugs: MESOS-5795
>     https://issues.apache.org/jira/browse/MESOS-5795
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> This added 'NvidiaGpuAllocator' to docker containerizer process so that
> docker containerizer process is ready to use it to allocate GPUs to task
> with 'gpus' resource.
> 
> 
> Diffs
> -----
> 
>   src/slave/containerizer/docker.hpp 43ca4317d608b3b43dd7bd0d1b55c721e7364885 
>   src/slave/containerizer/docker.cpp 12bad2db03bcf755317c654f028b628c5c407a62 
>   src/tests/mesos.hpp 9174a3810d0da34b99dc257e9c77f83107fdd9f5 
>   src/tests/mesos.cpp 30492d7e3b4c5e9ae9d2b2446cadba62d43a3c65 
> 
> Diff: https://reviews.apache.org/r/50123/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Yubo Li
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message