mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ammar Askar <am...@ammaraskar.com>
Subject Re: Review Request 50002: Allow all flags load methods to specify a prefix.
Date Thu, 14 Jul 2016 22:11:10 GMT


> On July 14, 2016, 1:27 a.m., Vinod Kone wrote:
> > 3rdparty/stout/tests/flags_tests.cpp, line 546
> > <https://reviews.apache.org/r/50002/diff/1/?file=1443425#file1443425line546>
> >
> >     s/test_option_map/values2/

Scoped so they can share the same name of `values`


- Ammar


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/50002/#review142181
-----------------------------------------------------------


On July 14, 2016, 10:10 p.m., Ammar Askar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/50002/
> -----------------------------------------------------------
> 
> (Updated July 14, 2016, 10:10 p.m.)
> 
> 
> Review request for mesos, Greg Mann and Vinod Kone.
> 
> 
> Bugs: MESOS-5613
>     https://issues.apache.org/jira/browse/MESOS-5613
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Allow all flags load methods to specify a prefix.
> 
> This also refactors the prefix logic into one place, so that's nice.
> Required for the actual fix for passing work_dir in local.
> 
> 
> Diffs
> -----
> 
>   3rdparty/stout/include/stout/flags/flags.hpp dd93627 
>   3rdparty/stout/tests/flags_tests.cpp 77f3a6a 
> 
> Diff: https://reviews.apache.org/r/50002/diff/
> 
> 
> Testing
> -------
> 
> Added additional tests to flags_tests.cpp to ensure that prefix works on the other methods.
> 
> `make check` passes
> 
> 
> Thanks,
> 
> Ammar Askar
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message