mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Anand Mazumdar <an...@apache.org>
Subject Re: Review Request 48511: Renamed `responseContentType` to `responseType`.
Date Mon, 13 Jun 2016 21:45:06 GMT


> On June 13, 2016, 9:29 p.m., Vinod Kone wrote:
> > hmm. i dont think `responseType` is that clear. what is a http response type? type
could as well refer to status code. or maybe accept type. `responseContentType` is explicit.

hmm .. The _type_ of the variable is `ContentType`. Hence, just having the variable name as
`responseType` is _intuitive_ to the reader that this refers to the content type of the response.
That being said, looks like this reasoning might not be that obvious.

How about just renaming it as `acceptType` to be more intuitive?


- Anand


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/48511/#review137385
-----------------------------------------------------------


On June 9, 2016, 9:30 p.m., Anand Mazumdar wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/48511/
> -----------------------------------------------------------
> 
> (Updated June 9, 2016, 9:30 p.m.)
> 
> 
> Review request for mesos, haosdent huang and Vinod Kone.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Minor: The type of the variable is already `ContentType`. The
> name `responseType` has sufficient information that this
> refers to the content type of the response.
> 
> 
> Diffs
> -----
> 
>   src/master/http.cpp 6e1bf9557a854a89fa9173223295816a9e114e7c 
>   src/master/master.hpp 2c45dab291a153b42809ab12e4252bf58559feeb 
>   src/slave/http.cpp 67ad7a92195abc266fd82fa5dc4c71f24a02aef3 
>   src/slave/slave.hpp da8b0d78af8611d22d66935e908e14977b242586 
> 
> Diff: https://reviews.apache.org/r/48511/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Anand Mazumdar
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message