mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alexander Rukletsov <ruklet...@gmail.com>
Subject Re: Review Request 46319: Added authorization to agents' `/monitor/statistics` endpoints.
Date Wed, 27 Apr 2016 15:29:56 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/46319/#review130770
-----------------------------------------------------------


Fix it, then Ship it!




I'll fix the remamining issues and commit it for you shortly.


src/slave/http.cpp (line 627)
<https://reviews.apache.org/r/46319/#comment194657>

    Indentation.



src/slave/http.cpp (line 628)
<https://reviews.apache.org/r/46319/#comment194697>

    Indentation.



src/slave/http.cpp (line 637)
<https://reviews.apache.org/r/46319/#comment194658>

    Indentation.



src/tests/slave_authorization_tests.cpp (lines 182 - 183)
<https://reviews.apache.org/r/46319/#comment194659>

    Wrap differently to avoid jaggeddness.



src/tests/slave_authorization_tests.cpp (line 197)
<https://reviews.apache.org/r/46319/#comment194661>

    Let's wrap `Return(true)` onto the next line for readability. It's much faster to grasp
what is going on when each action is on a separate line.



src/tests/slave_authorization_tests.cpp (line 199)
<https://reviews.apache.org/r/46319/#comment194678>

    You can omit `process::` prefix.



src/tests/slave_authorization_tests.cpp (line 207)
<https://reviews.apache.org/r/46319/#comment194662>

    You use it once, hence it doesn't really make sense to introduce a variable.



src/tests/slave_authorization_tests.cpp (line 234)
<https://reviews.apache.org/r/46319/#comment194679>

    Ditto.



src/tests/slave_authorization_tests.cpp (line 245)
<https://reviews.apache.org/r/46319/#comment194663>

    Looks like the first "for" is redundant.



src/tests/slave_authorization_tests.cpp (lines 253 - 255)
<https://reviews.apache.org/r/46319/#comment194664>

    Any reason why you don't just use `StartSlave`? It would also fit one line then.



src/tests/slave_authorization_tests.cpp (line 257)
<https://reviews.apache.org/r/46319/#comment194680>

    Ditto.



src/tests/slave_authorization_tests.cpp (line 268)
<https://reviews.apache.org/r/46319/#comment194656>

    "The tests are parameterized by the endpoint being queried."
    
    Add a `TODO` about also considering parameterizing the authz action, e.g. `authorization::GET_ENDPOINT_WITH_PATH`



src/tests/slave_authorization_tests.cpp (lines 268 - 272)
<https://reviews.apache.org/r/46319/#comment194667>

    Let's pull it up closer to `SlaveEndpointTest` fixture.


- Alexander Rukletsov


On April 27, 2016, 3:28 p.m., Benjamin Bannier wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/46319/
> -----------------------------------------------------------
> 
> (Updated April 27, 2016, 3:28 p.m.)
> 
> 
> Review request for mesos, Adam B, Alexander Rojas, and Jan Schlicht.
> 
> 
> Bugs: MESOS-5164
>     https://issues.apache.org/jira/browse/MESOS-5164
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added authorization to agents' `/monitor/statistics` endpoints.
> 
> 
> Diffs
> -----
> 
>   src/slave/http.cpp 537736d1fe42e8150bad91326299ef9a17041a8e 
>   src/slave/slave.hpp 57b18882e30e44dcc40449b0e3be8ee970c45bc8 
>   src/tests/slave_authorization_tests.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/46319/diff/
> 
> 
> Testing
> -------
> 
> make check (OS X, clang w/o optimization)
> `GTEST_FILTER="*SlaveEndpointTest*:*SlaveAuthorizationTest*" ./bin/mesos-tests.sh --gtest_repeat=100
--gtest_break_on_failure`
> 
> 
> Thanks,
> 
> Benjamin Bannier
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message