mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Guangya Liu <gyliu...@gmail.com>
Subject Re: Review Request 44837: Added force_pull_image to Image protobuf.
Date Sat, 02 Apr 2016 16:09:00 GMT


> On 三月 15, 2016, 4:42 p.m., Jie Yu wrote:
> > include/mesos/mesos.proto, line 1501
> > <https://reviews.apache.org/r/44837/diff/2/?file=1299390#file1299390line1501>
> >
> >     s/force_pull_image/no_cache/
> >     
> >     IMO, force pull is a mean, not a description. Please adjust the comments accordingly.
> 
> Gilbert Song wrote:
>     Shouldn't we make it consensus with docker containerizer?
> 
> Guangya Liu wrote:
>     Yes, I have the same question as Gilbert, the docker containerizer is now using `force_pull_image`,
shall we keep consistent? Just keep `force_pull_image` or use `no_cache` for both mesos containerizer
and docker containerizer?

@jieyu, any more comments? I'm OK to rename it to `no_cache`, but after rename, do we need
to file a bug to rename `force_pull_image` for docker containerizer to keep consistent?


- Guangya


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/44837/#review123681
-----------------------------------------------------------


On 三月 15, 2016, 7:31 a.m., Guangya Liu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/44837/
> -----------------------------------------------------------
> 
> (Updated 三月 15, 2016, 7:31 a.m.)
> 
> 
> Review request for mesos, haosdent huang and Jie Yu.
> 
> 
> Bugs: MESOS-4886
>     https://issues.apache.org/jira/browse/MESOS-4886
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Added force_pull_image to Image protobuf.
> 
> 
> Diffs
> -----
> 
>   include/mesos/mesos.proto deb9c0910a27afd67276f54b3f666a878212727b 
>   include/mesos/v1/mesos.proto a981e750c24cfc48177bbc9ca56f0c3ecfae1a1b 
> 
> Diff: https://reviews.apache.org/r/44837/diff/
> 
> 
> Testing
> -------
> 
> make
> make check
> 
> 
> Thanks,
> 
> Guangya Liu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message