mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Joris Van Remoortere" <joris.van.remoort...@gmail.com>
Subject Re: Review Request 39533: SSLTest refactor: Change test #ifdefs so this class exists with or without --enable-ssl.
Date Mon, 26 Oct 2015 21:57:12 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/39533/#review104086
-----------------------------------------------------------

Ship it!



3rdparty/libprocess/include/process/ssl/gtest.hpp (line 59)
<https://reviews.apache.org/r/39533/#comment162304>

    As per discussion offline, let's make this more readable by doing something like:
    ```
    // Your general comment.
    #ifndef USE_SSL_SOCKET
    class SSLTemporaryDirectoryTest : public TemporaryDirectoryTest {}
    #else
    class SSLTemporaryDirectoryTest : public TemporaryDirectoryTest
    {
      // SSL specific behaviour and helper functions.
    }
    #endif
    ```


- Joris Van Remoortere


On Oct. 22, 2015, 12:04 a.m., Joseph Wu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/39533/
> -----------------------------------------------------------
> 
> (Updated Oct. 22, 2015, 12:04 a.m.)
> 
> 
> Review request for mesos, Artem Harutyunyan and Joris Van Remoortere.
> 
> 
> Bugs: MESOS-3762
>     https://issues.apache.org/jira/browse/MESOS-3762
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> When `--enable-ssl` is not present, the body of the `SSLTemporaryDirectoryTest` is #ifdef'd
out,
> such that `SSLTemporaryDirectoryTest` is an empty wrapper around `TemporaryDirectoryTest`.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/include/process/ssl/gtest.hpp 91991f509e480a94de00c6bf20ff0abf083dda8a

> 
> Diff: https://reviews.apache.org/r/39533/diff/
> 
> 
> Testing
> -------
> 
> Testing done in the next review.
> 
> 
> Thanks,
> 
> Joseph Wu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message