mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kone" <vinodk...@gmail.com>
Subject Re: Review Request 34138: AppC hash computation.
Date Thu, 09 Jul 2015 18:47:27 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/34138/#review91145
-----------------------------------------------------------



src/slave/containerizer/provisioners/appc/hash.hpp (line 40)
<https://reviews.apache.org/r/34138/#comment144424>

    A class with only static methods seems weird. Why not put this in a namespace instead?
    
    Also, why is this defined here and not in libprocess?



src/slave/containerizer/provisioners/appc/hash.hpp (line 61)
<https://reviews.apache.org/r/34138/#comment144423>

    This should take a 'Path' type instead of 'string'.



src/slave/containerizer/provisioners/appc/hash.hpp (line 69)
<https://reviews.apache.org/r/34138/#comment144425>

    looks like 'command()' is only used once here. why split it into a function?


- Vinod Kone


On July 7, 2015, 7:42 p.m., Ian Downes wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/34138/
> -----------------------------------------------------------
> 
> (Updated July 7, 2015, 7:42 p.m.)
> 
> 
> Review request for mesos, Chi Zhang, Paul Brett, Timothy Chen, and Vinod Kone.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> AppC hash computation.
> 
> 
> Diffs
> -----
> 
>   src/Makefile.am e7de0f3d1a5efeaef47d5074defe3b40db94f573 
>   src/slave/containerizer/provisioners/appc/hash.hpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/34138/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Ian Downes
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message