mesos-reviews mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Rukletsov" <ruklet...@gmail.com>
Subject Re: Review Request 35694: Added helper constructors to hashmap.
Date Sat, 20 Jun 2015 19:35:40 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/35694/#review88661
-----------------------------------------------------------


Why do we use different approaches (emplace() and insert()) in c-tors? Is it possible to unify
them for clarity? If not, mind leaving a comment explaining the reasoning?


3rdparty/libprocess/3rdparty/stout/include/stout/hashmap.hpp (line 52)
<https://reviews.apache.org/r/35694/#comment141248>

    Let's avoid re-creating iterator:
    
    ```
    for (auto iterator = map.begin(), auto endIterator = map.end();
         iterator != endIterator;
         ++iterator) {
    ```



3rdparty/libprocess/3rdparty/stout/tests/hashmap_tests.cpp (line 32)
<https://reviews.apache.org/r/35694/#comment141249>

    Let's expand the test for move c-tor as well.


- Alexander Rukletsov


On June 20, 2015, 7:18 p.m., Benjamin Hindman wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/35694/
> -----------------------------------------------------------
> 
> (Updated June 20, 2015, 7:18 p.m.)
> 
> 
> Review request for mesos and Till Toenshoff.
> 
> 
> Bugs: MESOS-2832
>     https://issues.apache.org/jira/browse/MESOS-2832
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> See summary.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/hashmap.hpp 4f90d3dcd880b95f22ea13c56a61c7f981eea57d

>   3rdparty/libprocess/3rdparty/stout/tests/hashmap_tests.cpp 6a26d93a9a68ab18b7c9b25039a96b663a73a309

> 
> Diff: https://reviews.apache.org/r/35694/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Benjamin Hindman
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message