mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chun-Hung Hsiao (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MESOS-9066) Changing `CREATE_VOLUME` and `CREATE_BLOCK` to `CREATE_DISK`.
Date Tue, 10 Jul 2018 03:19:00 GMT
Chun-Hung Hsiao created MESOS-9066:
--------------------------------------

             Summary: Changing `CREATE_VOLUME` and `CREATE_BLOCK` to `CREATE_DISK`.
                 Key: MESOS-9066
                 URL: https://issues.apache.org/jira/browse/MESOS-9066
             Project: Mesos
          Issue Type: Task
          Components: storage
            Reporter: Chun-Hung Hsiao
            Assignee: Chun-Hung Hsiao


Mesos 1.5 introduced four new operations for better storage support through CSI. These operations
are:

  * CREATE_VOLUME converts RAW disks to MOUNT or PATH disks.
  * DESTROY_VOLUME converts MOUNT or PATH disks back to RAW disks.
  * CREATE_BLOCK converts RAW disks to BLOCK disks.
  * DESTROY_BLOCK converts BLOCK disks back to RAW disks.

However, the following two issues are raised for these operations:

1. "Volume" is overloaded and leads to conflicting/inconsistent naming.
2. The concept of "PATH" disks does not exist in CSI, which could be problematic.

To address this, we could change CREATE_VOLUME/CREATE_BLOCK to CREATE_DISK, and DESTROY_VOLUME/DESTROY_BLOCK
to DESTROY_DISK, and make CREATE_DISK support only MOUNT and BLOCK disks.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message