mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jan Schlicht (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MESOS-8867) CMake: Bundled libevent v2.1.5-beta doesn't compile with OpenSSL 1.1.0
Date Wed, 02 May 2018 12:04:00 GMT
Jan Schlicht created MESOS-8867:
-----------------------------------

             Summary: CMake: Bundled libevent v2.1.5-beta doesn't compile with OpenSSL 1.1.0
                 Key: MESOS-8867
                 URL: https://issues.apache.org/jira/browse/MESOS-8867
             Project: Mesos
          Issue Type: Bug
          Components: cmake
         Environment: Fedora 28 with OpenSSL 1.1.0h, {{cmake -G Ninja -D ENABLE_LIBEVENT=ON
-D ENABLE_SSL=ON}}
            Reporter: Jan Schlicht


Compiling libevent 2.1.5 beta with OpenSSL 1.1.0 fails with errors like
{noformat}
/home/vagrant/mesos/build/3rdparty/libevent-2.1.5-beta/src/libevent-2.1.5-beta/bufferevent_openssl.c:
In function ‘bio_bufferevent_new’:
/home/vagrant/mesos/build/3rdparty/libevent-2.1.5-beta/src/libevent-2.1.5-beta/bufferevent_openssl.c:112:3:
error: dereferencing pointer to incomplete type ‘BIO’ {aka ‘struct bio_st’}
  b->init = 0;
   ^~
{noformat}

As this is the version currently bundled by CMake, builds with {{ENABLE_LIBEVENT=ON, ENABLE_SSL=ON}}
will fail to compile.

Libevent supports OpenSSL 1.1.0 beginning with v2.1.7-rc (see https://github.com/libevent/libevent/pull/397)




--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message