mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "James Peach (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MESOS-5329) Unable to build on ARM64/AArch64 when using bundled 3rdparty libs
Date Wed, 11 Apr 2018 15:50:00 GMT

    [ https://issues.apache.org/jira/browse/MESOS-5329?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16434093#comment-16434093
] 

James Peach commented on MESOS-5329:
------------------------------------

[~janisz] What's the current state of arm64 build?

> Unable to build on ARM64/AArch64 when using bundled 3rdparty libs
> -----------------------------------------------------------------
>
>                 Key: MESOS-5329
>                 URL: https://issues.apache.org/jira/browse/MESOS-5329
>             Project: Mesos
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 0.28.1
>         Environment: I'm using openSUSE Tumbleweed: 
> - uname -a = Linux od3k 4.5.0-3-default #1 SMP Mon Mar 28 07:27:57 UTC 2016 (8cf0ce6)
aarch64 aarch64 aarch64 GNU/Linux
> - gcc --version = gcc (SUSE Linux) 5.3.1 20160301 [gcc-5-branch revision 233849]
> - java -version = openjdk version "9-internal"
> OpenJDK Runtime Environment (build 9-internal+0-2016-04-12-223414.abuild.jdk9-55b6d550828d)
> OpenJDK 64-Bit Server VM (build 9-internal+0-2016-04-12-223414.abuild.jdk9-55b6d550828d,
mixed mode)
> on an [Overdrive 3000|http://softiron.co.uk/products/]
>            Reporter: Andrew Wafaa
>            Priority: Major
>              Labels: easyfix
>
> Some of the supplied 3rdparty libraries are so outdated they do not have support for
64bit ARM. The following need to be updated before you can build from mesos source:
> * protobuf 2.5.0 -> 2.6.1
> * libev 4.15 -> 4.22
> If I disable the 3rdparty libraries and use those supplied by the OS all builds fine.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message