mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kapil Arya (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MESOS-8224) mesos.interface 1.4.0 cannot be installed with pip
Date Tue, 09 Jan 2018 23:35:00 GMT

     [ https://issues.apache.org/jira/browse/MESOS-8224?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kapil Arya updated MESOS-8224:
------------------------------
    Story Points: 1
          Sprint: Mesosphere Sprint 72

Packages available at:
https://pypi.python.org/pypi/mesos.interface/1.4.0
The following succeeds now:
{code}
python -m pip install --user mesos.interface==1.4.0
{code}

> mesos.interface 1.4.0 cannot be installed with pip
> --------------------------------------------------
>
>                 Key: MESOS-8224
>                 URL: https://issues.apache.org/jira/browse/MESOS-8224
>             Project: Mesos
>          Issue Type: Task
>          Components: release
>            Reporter: Bill Farner
>
> This breaks some framework development tooling.
> WIth latest pip:
> {noformat}
> $ python -m pip -V
> pip 9.0.1 from /Users/wfarner/code/aurora/build-support/python/pycharm.venv/lib/python2.7/site-packages
(python 2.7)
> {noformat}
> This works fine for previous releases:
> {noformat}
> $ python -m pip install mesos.interface==1.3.0
> Collecting mesos.interface==1.3.0
> ...
> Installing collected packages: mesos.interface
> Successfully installed mesos.interface-1.3.0
> {noformat}
> But it does not for 1.4.0:
> {noformat}
> $ python -m pip install mesos.interface==1.4.0
> Collecting mesos.interface==1.4.0
>   Could not find a version that satisfies the requirement mesos.interface==1.4.0 (from
versions: 0.21.2.linux-x86_64, 0.22.1.2.linux-x86_64, 0.22.2.linux-x86_64, 0.23.1.linux-x86_64,
0.24.1.linux-x86_64, 0.24.2.linux-x86_64, 0.25.0.linux-x86_64, 0.25.1.linux-x86_64, 0.26.1.linux-x86_64,
0.27.0.linux-x86_64, 0.27.1.linux-x86_64, 0.27.2.linux-x86_64, 0.28.0.linux-x86_64, 0.28.1.linux-x86_64,
0.28.2.linux-x86_64, 1.0.0.linux-x86_64, 1.0.1.linux-x86_64, 1.1.0.linux-x86_64, 1.2.0.linux-x86_64,
1.3.0.linux-x86_64, 0.20.0, 0.20.1, 0.21.0, 0.21.1, 0.21.2, 0.22.0, 0.22.1.2, 0.22.2, 0.23.0,
0.23.1, 0.24.0, 0.24.1, 0.24.2, 0.25.0, 0.25.1, 0.26.0, 0.26.1, 0.27.0, 0.27.1, 0.27.2, 0.28.0,
0.28.1, 0.28.2, 1.0.0, 1.0.1, 1.1.0, 1.2.0, 1.3.0)
> No matching distribution found for mesos.interface==1.4.0
> {noformat}
> Verbose output shows that pip skips the 1.4.0 distribution:
> {noformat}
> $ python -m pip install -v mesos.interface==1.4.0 | grep 1.4.0
> Collecting mesos.interface==1.4.0
>     Skipping link https://pypi.python.org/packages/ef/1b/d5b0c1456f755ad42477eaa9667e22d1f5fd8e2fce0f9b26937f93743f6c/mesos.interface-1.4.0-py2.7.egg#md5=32113860961d49c31f69f7b13a9bc063
(from https://pypi.python.org/simple/mesos-interface/); unsupported archive format: .egg
> {noformat}



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message