mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Raul Harnasch (JIRA)" <j...@apache.org>
Subject [jira] [Created] (MESOS-7290) make fails at protobuf stage
Date Wed, 22 Mar 2017 20:03:41 GMT
Raul Harnasch created MESOS-7290:
------------------------------------

             Summary: make fails at protobuf stage
                 Key: MESOS-7290
                 URL: https://issues.apache.org/jira/browse/MESOS-7290
             Project: Mesos
          Issue Type: Bug
    Affects Versions: 1.2.0
         Environment: CentOS 7.3 (built from 1611 image)

            Reporter: Raul Harnasch


{noformat}
Building protobuf Python egg ...
cd ../3rdparty/protobuf-2.6.1/python &&			\
  CC="gcc"					\
  CXX="g++"					\
  CFLAGS="-g1 -O0 -Wno-unused-local-typedefs"				\
  CXXFLAGS="-g1 -O0 -Wno-unused-local-typedefs -std=c++11"			\
  PYTHONPATH=/opt/mesos/build/3rdparty/setuptools-20.9.0	\
  /bin/python setup.py build bdist_egg

Installed /opt/mesos/build/3rdparty/protobuf-2.6.1/python/.eggs/google_apputils-0.4.2-py2.7.egg
Traceback (most recent call last):
  File "setup.py", line 200, in <module>
    "Protocol Buffers are Google's data interchange format.",
  File "/usr/lib64/python2.7/distutils/core.py", line 112, in setup
    _setup_distribution = dist = klass(attrs)
  File "/opt/mesos/build/3rdparty/setuptools-20.9.0/setuptools/dist.py", line 269, in __init__
    self.fetch_build_eggs(attrs['setup_requires'])
  File "/opt/mesos/build/3rdparty/setuptools-20.9.0/setuptools/dist.py", line 313, in fetch_build_eggs
    replace_conflicting=True,
  File "/opt/mesos/build/3rdparty/setuptools-20.9.0/pkg_resources/__init__.py", line 826,
in resolve
    dist = best[req.key] = env.best_match(req, ws, installer)
  File "/opt/mesos/build/3rdparty/setuptools-20.9.0/pkg_resources/__init__.py", line 1085,
in best_match
    dist = working_set.find(req)
  File "/opt/mesos/build/3rdparty/setuptools-20.9.0/pkg_resources/__init__.py", line 695,
in find
    raise VersionConflict(dist, req)
pkg_resources.VersionConflict: (pytz 2012d (/usr/lib/python2.7/site-packages), Requirement.parse('pytz>=2010'))
make[2]: *** [../3rdparty/protobuf-2.6.1/python/dist/protobuf-2.6.1-py2.7.egg] Error 1
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/opt/mesos/build/src'
make[1]: *** [all] Error 2
make[1]: Leaving directory `/opt/mesos/build/src'
make: *** [all-recursive] Error 1
{noformat}

Looks like a dependency issue, but as the error suggests, I have pytz 2012d when the minimum
requirement is 2010. Pip confirms this:
{noformat}
$ pip freeze | grep pytz
pytz===2012d
{noformat}



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message