mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "haosdent (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MESOS-5186) mesos.interface: Allow using protobuf 3.x
Date Mon, 06 Feb 2017 17:02:41 GMT

    [ https://issues.apache.org/jira/browse/MESOS-5186?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15854363#comment-15854363
] 

haosdent commented on MESOS-5186:
---------------------------------

1.2.0 would be cut in this week. Because this is not a minor change, actually it is a change
associated with protocol and compatibility. Let's don't review and ship in a hurry, otherwise
it would affect others production environment. We may discuss if could cherry pick it to 1.2.1
after 1.2.0 release.

> mesos.interface: Allow using protobuf 3.x
> -----------------------------------------
>
>                 Key: MESOS-5186
>                 URL: https://issues.apache.org/jira/browse/MESOS-5186
>             Project: Mesos
>          Issue Type: Improvement
>          Components: python api
>            Reporter: Myautsai PAN
>            Assignee: Yong Tang
>              Labels: protobuf, python
>
> We're working on integrating TensorFlow(https://www.tensorflow.org) with mesos. Both
the two require {{protobuf}}. The python package {{mesos.interface}} requires {{protobuf>=2.6.1,<3}},
but {{tensorflow}} requires {{protobuf>=3.0.0}} . Though protobuf 3.x is not compatible
with protobuf 2.x, but anyway we modify the {{setup.py}} (https://github.com/apache/mesos/blob/66cddaf/src/python/interface/setup.py.in#L29)
> from {{'install_requires': [ 'google-common>=0.0.1', 'protobuf>=2.6.1,<3' ],}}
to {{'install_requires': [ 'google-common>=0.0.1', 'protobuf>=2.6.1' ],}}
> It works fine. Would you please consider support protobuf 3.x officially in the next
release? Maybe just remove the {{,<3}} restriction is enough.



--
This message was sent by Atlassian JIRA
(v6.3.15#6346)

Mime
View raw message