mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Charles Allen (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MESOS-6097) Empty /etc/mesos-slave/hostname causes strange registration behavior
Date Fri, 26 Aug 2016 21:56:21 GMT

    [ https://issues.apache.org/jira/browse/MESOS-6097?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15439975#comment-15439975
] 

Charles Allen commented on MESOS-6097:
--------------------------------------

Filed https://github.com/mesosphere/mesos-deb-packaging/issues/89 , thanks!

> Empty /etc/mesos-slave/hostname causes strange registration behavior
> --------------------------------------------------------------------
>
>                 Key: MESOS-6097
>                 URL: https://issues.apache.org/jira/browse/MESOS-6097
>             Project: Mesos
>          Issue Type: Bug
>          Components: cli
>            Reporter: Charles Allen
>
> Using the mesosphere packaged Mesos 1.0.0 I had a node that ended up with a blank /etc/mesos-slave/hostname
due to something going wrong during the auto-config process.
> When the agent registered with the master, it ended up reporting very strangely, including
reporting the agent IP as the master's and having a master IP blank.
> The following items are in the /etc config:
> {code}
> $ ls /etc/mesos-slave/
> attributes  cgroups_hierarchy  cgroups_limit_swap  gc_delay  hostname  isolation  resources
 slave_subsystems  work_dir
> {code}
> Not sure if this is the right place to report mesosphere package config problems, but
it seems odd the agent would start under such a broken config.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message