mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Sunzhe (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MESOS-5896) When start Mesos container and docker images, it does not work.
Date Wed, 03 Aug 2016 06:45:20 GMT

    [ https://issues.apache.org/jira/browse/MESOS-5896?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15405431#comment-15405431
] 

Sunzhe commented on MESOS-5896:
-------------------------------

Hi Gilbert,

Thank you very much! I have finished the test with the specified {{\-\-docker_registry}}.
I think that is the  question of proxy. 

But I have a question: If I want to start a task with Mesos CLI {{mesos\-execute}}, how can
I specify the resources of the command/images? I specify the flag {{\-\-resources=cpus:4;mem:1024;disk:2048}},
but it seems that only the cpus is right(4), the memory, disk are 0. I know if I do not specify
the flag {{\-\-resources}}, the default value is cpus:1, mem:128.
The full parameter of the {{mesos\-execute}} is below:
{code}
 27 ./src/mesos-execute \
 28           --master=${MESOS_MASTER_IP}:5050 \
 29           --name=${INSTANCE_NAME} \
 30           --docker_image=${DOCKER_IMAGE} \
 31           --framework_capabilities=GPU_RESOURCES \
 32           --shell=false \
 33           --resources=cpus:4;mem:1024;disk:2048;gpus:1
{code}
And I made some attempt, the flag {{--resources}} with the first value is available(like the
above, cpus is 4), the rest are all 0(e.g. mem:0, disk:0, gpus:0) in Mesos web page.
Do you have any idea?

> When start Mesos container and docker images, it does not work.
> ---------------------------------------------------------------
>
>                 Key: MESOS-5896
>                 URL: https://issues.apache.org/jira/browse/MESOS-5896
>             Project: Mesos
>          Issue Type: Bug
>          Components: docker
>    Affects Versions: 1.0.0
>            Reporter: Sunzhe
>              Labels: containerizer
>
> When I create Mesos container with docker image, like this:
> {code:title=test.json|borderStyle=solid}
> {
> 	"id": "test-mesos-container-docker-image",
> 	"cmd": "while [ true ]; do uname -a; sleep 3; done",
> 	"cpus": 0.5,
> 	"mem": 32.0,
> 	"container": {
> 		"type": "MESOS",
> 		"mesos": {
> 		    "image": {
> 		        "type": "DOCKER",
> 		        "docker": {
> 		            "name": "ubuntu:14.04"
> 		        }
> 		    },
> 		    "network": "BRIDGE",
>             "portMappings": [
>               {
>                 "containerPort": 8080,
>                 "hostPort": 0,
>                 "servicePort": 10008,
>                 "protocol": "tcp",
>                 "labels": {}
>               }
>             ],
>             "privileged": false,
>             "parameters": [],
>             "forcePullImage": false
> 		}
> 	}
> }
> {code}
> It does not wok! The result seems Docker image does not work, the container uses host
filesystem not the Docker image.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message