mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "gtin (JIRA)" <j...@apache.org>
Subject [jira] [Comment Edited] (MESOS-5838) Failed to compile mesos on arm64 due to leveldb lack of support for arm64
Date Thu, 14 Jul 2016 02:15:21 GMT

    [ https://issues.apache.org/jira/browse/MESOS-5838?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=15376180#comment-15376180
] 

gtin edited comment on MESOS-5838 at 7/14/16 2:14 AM:
------------------------------------------------------

Thanks Vinod.  I followed the instructions on contributing to mesos to create an account at
apache reviews board but I am having trouble uploading the patch file.  I first created a
diff file using "git format-patch master --stdout > leveldb-1.4.patch" and the review board
complained that it needs to be a full index but when I created with the full index option
I got this error:

The specified diff file could not be parsed.
Line undefined: error: unable to find b71bf02c69155be6d0ec61fd8b2d8c2b42dfea1a fatal: git
cat-file b71bf02c69155be6d0ec61fd8b2d8c2b42dfea1a: bad file

The patch does apply successfully on the leveldb 1.4 code base with either full index or short
index.


was (Author: gtinjr@gmail.com):
Thanks Vinod.  I followed the instructions on contributing to mesos to create an account at
apache reviews board but I am having trouble uploading the patch file.  I first created a
diff file using "git format-patch master --full-index --stdout > leveldb-1.4.patch" and
the review board complained that it needs to be a full index but when I created with the full
index option I got this error:

The specified diff file could not be parsed.
Line undefined: error: unable to find b71bf02c69155be6d0ec61fd8b2d8c2b42dfea1a fatal: git
cat-file b71bf02c69155be6d0ec61fd8b2d8c2b42dfea1a: bad file

The patch does apply successfully on the leveldb 1.4 code base with either full index or short
index.

> Failed to compile mesos on arm64 due to leveldb lack of support for arm64
> -------------------------------------------------------------------------
>
>                 Key: MESOS-5838
>                 URL: https://issues.apache.org/jira/browse/MESOS-5838
>             Project: Mesos
>          Issue Type: Bug
>          Components: build
>    Affects Versions: 1.0.0
>         Environment: debian-jessie, odroid c2, arm64
>            Reporter: gtin
>              Labels: arm64, build
>
> ./port/atomic_pointer.h:142:2: error: #error Please implement AtomicPointer for this
platform.
>  #error Please implement AtomicPointer for this platform.
>   ^
> Makefile:74: recipe for target 'libleveldb.so.1.4' failed
> leveldb project master branch contains changes in atomic_porinter.h to support arm 64
build.  
> When I copy the contents of atomic_pointer.h from the leveldb master branch into the
mesos expanded leveldb 1.4 port/atomic_pointer.h, the code compiles without errors. The latest
leveldb release 1.18 does not support arm64 but master does.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message