mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Kevin Klues (JIRA)" <j...@apache.org>
Subject [jira] [Assigned] (MESOS-5717) Can't autodiscovery GPU resources without '--enable-nvidia-gpu-support' and '--nvidia_gpu_devices' flags
Date Tue, 28 Jun 2016 02:24:57 GMT

     [ https://issues.apache.org/jira/browse/MESOS-5717?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Kevin Klues reassigned MESOS-5717:
----------------------------------

    Assignee: Kevin Klues

> Can't autodiscovery GPU resources without '--enable-nvidia-gpu-support' and '--nvidia_gpu_devices'
flags
> --------------------------------------------------------------------------------------------------------
>
>                 Key: MESOS-5717
>                 URL: https://issues.apache.org/jira/browse/MESOS-5717
>             Project: Mesos
>          Issue Type: Bug
>         Environment: RHEL 7.2
>            Reporter: Sunzhe
>            Assignee: Kevin Klues
>              Labels: gpu
>             Fix For: 1.0.0
>
>
> Prerequisite: In MESOS\-5257  "By default, with no '\-\-nvidia_gpu_devices' flag or `gpus`
resources flag, the new auto-discovery will simply enumerate all of the GPUs on the system"
and in MESOS\-5630 "removes this flag(\-\-enable-nvidia-gpu-support) and enables this support
for all builds on Linux."
> So, I '../configure' without any flag, and start agent without '\-\-resources' or '\-\-nvidia_gpu_devices'
,  but can not discovery GPU resources, and I also start agent with '\-\-resources' and '\-\-nvidia_gpu_devices'
, it also does not work.
> I'm sure the NVIDIA GPUs on my machines are OK, because with '\-\-enable-nvidia-gpu-support'
when './configure' and with '\-\-resources', '\-\-nvidia_gpu_devices' when starting agents
it works well.



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message