mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guangya Liu (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MESOS-2513) FrameworkID not set in FrameworkInfo sent to Slave as part of RunTaskMessage
Date Thu, 10 Sep 2015 08:49:46 GMT

    [ https://issues.apache.org/jira/browse/MESOS-2513?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=14738419#comment-14738419
] 

Guangya Liu commented on MESOS-2513:
------------------------------------

I think that this is not a problem now as the FrameworkID was always set after https://reviews.apache.org/r/36720
, [~karya] , any comments on this? Thanks.

> FrameworkID not set in FrameworkInfo sent to Slave as part of RunTaskMessage
> ----------------------------------------------------------------------------
>
>                 Key: MESOS-2513
>                 URL: https://issues.apache.org/jira/browse/MESOS-2513
>             Project: Mesos
>          Issue Type: Bug
>            Reporter: Kapil Arya
>            Assignee: Kapil Arya
>              Labels: mesosphere
>
> While working on creating the decorator/undecorator hooks we realized that in one of
our slave hooks, we receive a FrameworkInfo which doesn't have the 'id' field set. As it turns
out, the FrameworkInfo sent by Master to Slave as part of the RunTaskMessage is missing the
id as well. In fact, the Master also sends a FrameworkID separately as part of the RunTaskMessage.
> Why not modify the Master to always set 'id' in FrameworkInfo before sending it with
RunTaskMessage. Would this affect the correctness?



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message