mesos-issues mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Till Toenshoff (JIRA)" <j...@apache.org>
Subject [jira] [Updated] (MESOS-1893) Authenticator Module: Location and Naming
Date Wed, 22 Oct 2014 21:31:33 GMT

     [ https://issues.apache.org/jira/browse/MESOS-1893?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Till Toenshoff updated MESOS-1893:
----------------------------------
    Description: 
h4. Motivation
Render a well structured and mesos-alike naming and folder tree. This shall be similar to
what we know from the awesome! containerizer structure.

h4. Folder Structure
For the flat-file Authenticator Module but also for authentication as a whole, I would like
to propose the following structural changes:

- move {{authenticator.hpp}} out of {{sasl/}}
- create a new {{authentication/}}
-- put the module interface here and name it {{authenticator.hpp}}
- create a new {{authentication/cram_md5}}
-- put the default/module implementation here and name it {{authenticator.hpp}} 
-- mind that I am proposing {{cram_md5}} instead of {{sasl}} due to the fact that cyrus-sasl2
offers many more mechanisms but our current default (CRAM-MD5) and further dividing the tree
into sasl and non-sasl based authentications may be too verbosive/bloated.

h4. Module Naming
Following the module naming scheme, I would like to propose {{org_apache_mesos_authenticator_crammd5}}
to be used for our first/default Authenticator. Mind that in this case I did not reflect the
folder tree into this reverse domain alike description as I find it more intuitive to have
the module before the kind - objections?

h4. Library Naming
Given that we will also add an authenticatee to this library, a proper name would be 
{{libauthentication_crammd5.so/dylib}}


  was:
h4. Motivation
Render a well structured and mesos-alike naming and folder tree. This shall be similar to
what we know from the awesome! containerizer structure.

h4. Folder Structure
For the flat-file Authenticator Module but also for authentication as a whole, I would like
to propose the following structural changes:

- move {{authenticator.hpp}} out of {{sasl/}}
- create a new {{authentication/}}
-- put the module interface here and name it {{authenticator.hpp}}
- create a new {{authentication/cram_md5/authenticator/}}
-- put the module implementation here and name it {{authenticator.hpp}} 
-- mind that I am proposing {{cram_md5}} instead of {{sasl}} due to the fact that cyrus-sasl2
offers many more mechanisms but our current default (CRAM-MD5) and further dividing the tree
into sasl and non-sasl based authentications may be too verbosive/bloated.

h4. Module Naming
Following the module naming scheme, I would like to propose {{org_apache_mesos_authenticator_crammd5}}
to be used for our first/default Authenticator. Mind that in this case I did not reflect the
folder tree into this reverse domain alike description as I find it more intuitive to have
the module before the kind - objections?

h4. Library Naming
Given that we will also add an authenticatee to this library, a proper name would be 
{{libauthentication_crammd5.so/dylib}}



> Authenticator Module: Location and Naming
> -----------------------------------------
>
>                 Key: MESOS-1893
>                 URL: https://issues.apache.org/jira/browse/MESOS-1893
>             Project: Mesos
>          Issue Type: Improvement
>          Components: modules
>            Reporter: Till Toenshoff
>            Assignee: Till Toenshoff
>            Priority: Blocker
>
> h4. Motivation
> Render a well structured and mesos-alike naming and folder tree. This shall be similar
to what we know from the awesome! containerizer structure.
> h4. Folder Structure
> For the flat-file Authenticator Module but also for authentication as a whole, I would
like to propose the following structural changes:
> - move {{authenticator.hpp}} out of {{sasl/}}
> - create a new {{authentication/}}
> -- put the module interface here and name it {{authenticator.hpp}}
> - create a new {{authentication/cram_md5}}
> -- put the default/module implementation here and name it {{authenticator.hpp}} 
> -- mind that I am proposing {{cram_md5}} instead of {{sasl}} due to the fact that cyrus-sasl2
offers many more mechanisms but our current default (CRAM-MD5) and further dividing the tree
into sasl and non-sasl based authentications may be too verbosive/bloated.
> h4. Module Naming
> Following the module naming scheme, I would like to propose {{org_apache_mesos_authenticator_crammd5}}
to be used for our first/default Authenticator. Mind that in this case I did not reflect the
folder tree into this reverse domain alike description as I find it more intuitive to have
the module before the kind - objections?
> h4. Library Naming
> Given that we will also add an authenticatee to this library, a proper name would be

> {{libauthentication_crammd5.so/dylib}}



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

Mime
View raw message