mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andrew Schwartzmeyer <and...@schwartzmeyer.com>
Subject Re: [Action Required] Install Python >= 3.6 to continue using the support scripts
Date Tue, 04 Sep 2018 20:14:38 GMT
This patch is landing TODAY. The Python 2 support scripts will no longer 
be available in... an hour or so.

Thanks all for testing,

Andy

On 08/31/2018 2:45 am, Armand Grillet wrote:
> Hi all,
> 
> Previously announced for July 1st, the update of the support scripts to
> Python 3 is now in its final phase. This requires you to install Python 
> >=
> 3.6 on your dev machine and have it available using *python3 *in order 
> to
> continue using the Mesos support scripts easily.
> 
> To make sure that you are ready, run:
> $ python --version
> $ python3 --version
> 
>    - If the first command returns a version of Python >= 2.6 and the 
> second
>    command returns a version of Python >= 3.6, your setup should work 
> with
>    master and on previous branches as well.
>    - If python3 does not exist or is Python < 3.6, update it to Python 
> >=
>    3.6. If you do not know how to do it, please ping the #python3 Mesos 
> Slack
>    channel.
>    - If both commands return Python >= 3.6, welcome to the future. You 
> are
>    then unable to build the Python bindings but building Mesos with
> --disable-python
>    and using the new support scripts work.
> 
> This change does not impact our build requirements, Python 2 is still 
> used
> to create the Python bindings and it is the only Python component built 
> by
> default.
> 
> As a reminder, updating our support scripts to Python 3 is done to fix
> bugs, go along the upgrade of the Mesos CLI / Python package to Python 
> 3,
> and be ready for Python 2 retirement <https://pythonclock.org/>.
> 
> If you have any questions, please answer to this email or write a 
> message
> in the #python3 Mesos Slack channel.
> 
> Thanks,
> Armand Grillet

Mime
View raw message