mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Yu Wei <yu20...@hotmail.com>
Subject launch marathon app but no leave "waiting" on mesos
Date Mon, 15 Aug 2016 10:05:37 GMT
Hi guys,

I'm running a simple marathon application "An Inline Shell Script".

After deploying, the app doesn't leave "waiting".


In mesos/state, I found following stuff.

"root_submissions":"true","user_sorter":"drf","version":"false","webui_dir":"\/usr\/local\/share\/mesos\/webui","work_dir":"\/opensrc\/cloud\/workbench","zk_session_timeout":"10secs"},"slaves":[{"id":"5c79ff49-8180-4d0b-8fcd-82eaf47c5a72-S0","pid":"slave(1)@127.0.1.1:5051","hostname":"jared-QiTianM4550-D680","registered_time":1471247912.3384,"reregistered_time":1471250972.04209,"resources":{"disk":516395.0,"mem":14970.0,"gpus":0.0,"cpus":8.0,"ports":"[31000-32000]"},"used_resources":{"disk":0.0,"mem":0.0,"gpus":0.0,"cpus":0.0},"offered_resources":{"disk":0.0,"mem":0.0,"gpus":0.0,"cpus":0.0},"reserved_resources":{},"unreserved_resources":{"disk":516395.0,"mem":14970.0,"gpus":0.0,"cpus":8.0,"ports":"[31000-32000]"},"attributes":{},"active":true,"version":"1.1.0"}],"frameworks":[],"completed_frameworks":[],"orphan_tasks":[],"unregistered_frameworks":[]}


I started mesos master and agent as below,

sudo mesos-master --work_dir=/opensrc/cloud/workbench

sudo mesos-agent --master=127.0.1.1:5050 --containerizers=docker,mesos --isolation=docker/runtime,filesystem/linux
--work_dir=/opensrc/cloud/workbench --image_providers=docker


Then I launched marathon as below,

bin/start --master localhost:2181/mesos --zk zk://localhost:2181/marathon --logging_level
DEBUG


Then create app to execute simple shell command, it doesn't leave waiting.  Do I need to specify
image for docker/container?


Any advice?


Jared, (??)
Software developer
Interested in open source software, big data, Linux

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message