mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Adam Bordelon <a...@mesosphere.io>
Subject Re: Change minimum supported version for GCC to 4.8.1
Date Tue, 05 Jan 2016 00:07:27 GMT
+1

On Mon, Jan 4, 2016 at 3:19 PM, Joris Van Remoortere <
joris.van.remoortere@gmail.com> wrote:

> +1 (binding)
>
> I would like to propose that we bump our minimum supported version for gcc
> > from 4.8.0 to 4.8.1. The main motivation behind this is that there are at
> > least 2 outstanding reviews on RB that want to use ref-qualifiers <
> > http://www.open-std.org/jtc1/sc22/wg21/docs/papers/2007/n2439.htm>
> > introduced in GCC 4.8.1. The reviews in question are r41870 <
> > https://reviews.apache.org/r/41870> and r41593 <
> > https://reviews.apache.org/r/41593/diff/2?file=1173648#file1173648line58
> >.
> >
> > Also, our Getting Started document <
> > http://mesos.apache.org/gettingstarted/> for Mesos already lists the
> > minimum gcc version as > 4.8. Looking at the release timeline <
> > https://gcc.gnu.org/gcc-4.8/> for GCC, it seems that 4.8.0/4.8.1 were
> > released within a week of each other.
> >
> > Does anyone have a strong opinion against this change ?
> >
> > -anand
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message