mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From haosdent <haosd...@gmail.com>
Subject Re: Patch for the website's Rakefile
Date Sat, 03 Oct 2015 06:00:41 GMT
I remember we also have another patches to fixes the error link generation
in rakefile. And seems current website generation way a bit hard to
maintain.
On Oct 3, 2015 10:35 AM, "Jake Farrell" <jfarrell@apache.org> wrote:

> I am currently not a Mesos committer so can not help shepard this through,
> but I did help write the website code and have tested and verified this
> patch does take care of the problem outlined. steps to help any committer
> not familiar with the website code listed below. ping if you have questions
> or need help
>
> -Jake
>
>
> svn co https://svn.apache.org/repos/asf/mesos/site
> patch -p0 < rake.patch
> bundle install
> rake (rake dev if you want to test the site locally)
> svn add publish/documentation/latest/images
> source/documentation/latest/images
> svn commit ...
>
>
>
> On Fri, Oct 2, 2015 at 12:29 PM, Dave Lester <dave@davelester.org> wrote:
>
> > Unfortunately I don't have time the next few weeks to assist -- but all
> > committers do have access to the site and should be able to review /
> > merge this.
> >
> > Best,
> > Dave
> >
> > On Fri, Oct 2, 2015, at 09:23 AM, Joseph Wu wrote:
> > > Dave,
> > >
> > > Would it be possible for you to take a look at the patches in
> MESOS-3183
> > > <https://issues.apache.org/jira/browse/MESOS-3183>?
> > >
> > > Ideally, we should fix the documentation before 0.25 goes out.
> > >
> > > Thanks,
> > > ~Joseph
> > >
> > > On Mon, Sep 28, 2015 at 1:59 PM, Joseph Wu <joseph@mesosphere.io>
> wrote:
> > >
> > > > + Dev
> > > >
> > > >
> > > > On Mon, Sep 28, 2015 at 1:56 PM, Dave Lester <dlester@twitter.com>
> > wrote:
> > > >
> > > >> Can this be discussed on the mailing list? Thanks
> > > >>
> > > >>
> > > >> On Monday, September 28, 2015, Joseph Wu <joseph@mesosphere.io>
> > wrote:
> > > >>
> > > >>> + Niq, Joris, MPark (so that this doesn't get neglected when the
> > website
> > > >>> is updated for the 0.25 release).
> > > >>>
> > > >>> Both patches (for the website and for the docs) will be tracked
> here:
> > > >>> https://issues.apache.org/jira/browse/MESOS-3183
> > > >>>
> > > >>> Feedback/reviews would be appreciated,
> > > >>> ~Joseph
> > > >>>
> > > >>> On Tue, Sep 22, 2015 at 11:48 AM, Adam Bordelon <
> adam@mesosphere.io>
> > > >>> wrote:
> > > >>>
> > > >>>> Unfortunately, we don't have RB synced up to our svn repo.
> > Submitting
> > > >>>> raw patches has been best practice so far (AFAIK)
> > > >>>>
> > > >>>> On Tue, Sep 22, 2015 at 11:35 AM, Joseph Wu <joseph@mesosphere.io
> >
> > > >>>> wrote:
> > > >>>>
> > > >>>>> Looks like this has been an issue since the end of July
(!).
> > > >>>>> https://issues.apache.org/jira/browse/MESOS-3183
> > > >>>>>
> > > >>>>> Is there a reviewboard equivalent for modifications to
the
> website
> > > >>>>> like this patch?
> > > >>>>> ~Joseph
> > > >>>>>
> > > >>>>> On Mon, Sep 21, 2015 at 2:56 PM, Vinod Kone <vinod@twitter.com>
> > wrote:
> > > >>>>>
> > > >>>>>> +dave lester who previously looked into the image
loading issue.
> > > >>>>>>
> > > >>>>>>
> > > >>>>>> @vinodkone
> > > >>>>>>
> > > >>>>>> On Mon, Sep 21, 2015 at 2:50 PM, Joseph Wu <
> joseph@mesosphere.io>
> > > >>>>>> wrote:
> > > >>>>>>
> > > >>>>>>> Hi Adam/Vinod,
> > > >>>>>>>
> > > >>>>>>> Documentation images aren't being published to
the website.  A
> > few
> > > >>>>>>> places with image(s):
> > > >>>>>>> *
> > > >>>>>>>
> > http://mesos.apache.org/documentation/latest/external-containerizer/
> > > >>>>>>> * Or
> > http://mesos.apache.org/documentation/latest/oversubscription/
> > > >>>>>>> * Or http://mesos.apache.org/documentation/latest/maintenance/
> > > >>>>>>> <-* ;(*
> > > >>>>>>>
> > > >>>>>>> I've attached a patch which sort-of fixes this.
 It only
> sort-of
> > > >>>>>>> works because the images are copied to the website,
*BUT* for
> > them
> > > >>>>>>> to show up, you need to remove the trailing slash
"/" from the
> > URL.
> > > >>>>>>>
> > > >>>>>>> I'll submit a separate patch on RB for changing
all image URLs
> > from
> > > >>>>>>> "images/*" to "/documentation/latest/images/*",
so that they
> > show up
> > > >>>>>>> regardless of the slash:
> > > >>>>>>> https://reviews.apache.org/r/38570/
> > > >>>>>>>
> > > >>>>>>> ~Joseph
> > > >>>>>>>
> > > >>>>>>
> > > >>>>>>
> > > >>>>>
> > > >>>>
> > > >>>
> > > >>
> > > >> --
> > > >> @davelester
> > > >> Open Source Advocate | Twitter, Inc
> > > >> #MesosCon Europe Co-Chair
> > > >>
> > > >>
> > > >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message