mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From haosdent <haosd...@gmail.com>
Subject Re: brew install mesos doesn't work for 0.24.0
Date Tue, 15 Sep 2015 11:39:55 GMT
hi @vinod Because we add python cli package in
https://issues.apache.org/jira/browse/MESOS-3149

When you write the homebrew file, this line
https://github.com/Homebrew/homebrew/blob/master/Library/Formula/mesos.rb#L98
>    ["native", "interface", ""].each do |p|

should change to
>    ["native", "interface", "cli", ""].each do |p|

If anything I could help you in homebrew, email me directly. Thank you in
advance.


On Tue, Sep 15, 2015 at 1:15 PM, Vinod Kone <vinodkone@gmail.com> wrote:

> Fwiw, mesos does have a --with-svn option which looks at the correct
> homebrew directory.  My guess is that the python toolchain doesn't pickup
> the with-svn path.
>
> @vinodkone
>
> > On Sep 14, 2015, at 10:01 PM, Marco Massenzio <marco@mesosphere.io>
> wrote:
> >
> > Thanks, James.
> > I don't suppose, then, that simply doing:
> >
> > LD_LIBRARYPATH=/opt/twitter:$LD_LIBRARYPATH
> >
> > would solve the issue?
> >
> >
> > *Marco Massenzio*
> >
> > *Distributed Systems Engineerhttp://codetrips.com <http://codetrips.com
> >*
> >
> >> On Mon, Sep 14, 2015 at 7:44 PM, James Peach <jorgar@gmail.com> wrote:
> >>
> >>
> >>> On Sep 14, 2015, at 4:51 PM, Vinod Kone <vinodkone@gmail.com> wrote:
> >>>
> >>> I do fine libsvn_delta libs in my file system
> >>>
> >>> ➜  twitter git:(vinod/0.24.0) ✗ sudo find / -name "*svn_delta*"
> >>>
> >>> Password:
> >>>
> >>>
> /Applications/Xcode.app/Contents/Developer/usr/lib/libsvn_delta-1.0.dylib
> >>>
> >>> /Applications/Xcode.app/Contents/Developer/usr/lib/libsvn_delta-1.dylib
> >>>
> >>> /Library/Developer/CommandLineTools/usr/lib/libsvn_delta-1.0.dylib
> >>>
> >>> /Library/Developer/CommandLineTools/usr/lib/libsvn_delta-1.dylib
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.13/include/subversion-1/svn_delta.h
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.13/lib/libsvn_delta-1.0.dylib
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.13/lib/libsvn_delta-1.a
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.13/lib/libsvn_delta-1.dylib
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.9/include/subversion-1/svn_delta.h
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.9/lib/libsvn_delta-1.0.dylib
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.9/lib/libsvn_delta-1.a
> >>>
> >>> /opt/twitter/Cellar/subversion/1.8.9/lib/libsvn_delta-1.dylib
> >>>
> >>> /opt/twitter/lib/libsvn_delta-1.0.dylib
> >>>
> >>> /opt/twitter/lib/libsvn_delta-1.a
> >>>
> >>> /opt/twitter/lib/libsvn_delta-1.dylib
> >>>
> >>> But clang doesn't seem to find them. Also, I expected to see a "-L"
> >>> pointing to brew's subversion directory (based on configure.ac and
> >> config
> >>> params), but I don't?
> >>
> >> Homebrew's default is to install into /usr/local which is in the default
> >> toolchain search path (which is why it is the Homebrew default). There's
> >> nothing that will find it in /opt/twitter unless Mesos adds a
> >> --with-subversion autoconf option. Once you are successfully linking
> >> against the Homebrew version, there is a trap where you can get a mix of
> >> Homebrew and system svn libraries. I forget the exact path that hits
> this,
> >> but you'll know because the tests crash in svn code. The fix is to force
> >> all the Homebrew stuff to build against the Homebrew svn, not the system
> >> one (phew!).
> >>
> >>>
> >>> I see some related discussion on MESOS-2448
> >>> <https://issues.apache.org/jira/browse/MESOS-2448> and the related
> >> GitHub
> >>> PR, but the issues seem to have been fixed. cc @TimChen
> >>>
> >>>
> >>>
> >>> On Mon, Sep 14, 2015 at 4:01 PM, Marco Massenzio <marco@mesosphere.io>
> >>> wrote:
> >>>
> >>>> Looks like you may need to update/install XCode on your Mac, perhaps?
> >>>>
> >>>> $ find / |grep svn_delta
> >>>> ...
> >>
> /Applications/Xcode.app/Contents/Developer/usr/lib/libsvn_delta-1.0.dylib
> >>>>
> /Applications/Xcode.app/Contents/Developer/usr/lib/libsvn_delta-1.dylib
> >>>> /Library/Developer/CommandLineTools/usr/lib/libsvn_delta-1.0.dylib
> >>>> /Library/Developer/CommandLineTools/usr/lib/libsvn_delta-1.dylib
> >>>> ...
> >>>>
> >>>> (this is where my understanding of homebrew ends, I'm afraid)
> >>>>
> >>>> *Marco Massenzio*
> >>>>
> >>>> *Distributed Systems Engineerhttp://codetrips.com <
> http://codetrips.com
> >>> *
> >>>>
> >>>> On Mon, Sep 14, 2015 at 3:52 PM, Vinod Kone <vinodkone@apache.org>
> >> wrote:
> >>>>
> >>>>> I'm trying to update the homebrew formula per the release guide
> >>>>> <http://mesos.apache.org/documentation/latest/release-guide/>.
> >>>>>
> >>>>> But when following instructions from homebrew regarding testing
the
> >>>> changes
> >>>>> <
> >>
> https://github.com/Homebrew/homebrew/blob/master/share/doc/homebrew/How-To-Open-a-Homebrew-Pull-Request-(and-get-it-merged).md#how-to-open-a-homebrew-pull-request-and-get-it-merged
> >>>>> (all
> >>>>> I changed was the version of Mesos and the sha) before sending a
PR,
> I
> >>>> get
> >>>>> the below error. Any ideas?
> >>>>>
> >>>>> ➜  twitter git:(vinod/0.24.0) ✗ brew install mesos &&
brew test mesos
> >>>>>
> >>>>> ==> Downloading
> >>
> https://www.apache.org/dyn/closer.cgi?path=mesos/0.24.0/mesos-0.24.0.tar.gz
> >>>>>
> >>>>> Already downloaded: /Library/Caches/Homebrew/mesos-0.24.0.tar.gz
> >>>>>
> >>>>> ==> Downloading
> >>>>> https://pypi.python.org/packages/source/b/boto/boto-2.36.0.tar.gz
> >>>>>
> >>>>> Already downloaded:
> /Library/Caches/Homebrew/mesos--boto-2.36.0.tar.gz
> >>>>>
> >>>>> ==> python -c import setuptools... --no-user-cfg install
> >>>>> --prefix=/opt/twitter/Cellar/mesos/0.24.0/libexec/boto
> >>>>> --single-version-externally-managed --record=installed.txt
> >>>>>
> >>>>> ==> ./configure --disable-python
> >>>> --prefix=/opt/twitter/Cellar/mesos/0.24.0
> >>>>> --disable-silent-rules --with-svn=/opt/twitter/opt/subversion
> >>>>>
> >>>>> ==> make
> >>>>>
> >>>>> ==> make install
> >>>>>
> >>>>> ==> ./configure --enable-python
> >> --prefix=/opt/twitter/Cellar/mesos/0.24.0
> >>>>> --disable-silent-rules --with-svn=/opt/twitter/opt/subversion
> >>>>>
> >>>>> ==> python -c import setuptools... --no-user-cfg install
> >>>>> --prefix=/opt/twitter/Cellar/mesos/0.24.0
> >>>>> --single-version-externally-managed --record=installed.txt
> >>>>>
> >>>>> /usr/bin/clang++ -std=c++11 -stdlib=libc++ -DNDEBUG -g -fwrapv -Os
> >> -Wall
> >>>>> -Wstrict-prototypes -Os -w -pipe -march=native
> >> -mmacosx-version-min=10.9
> >>
> -I/Library/Java/JavaVirtualMachines/jdk1.7.0_60.jdk/Contents/Home/include
> >>
> -I/Library/Java/JavaVirtualMachines/jdk1.7.0_60.jdk/Contents/Home/include/darwin
> >>>>> -I/opt/twitter/opt/openssl/include -I/opt/twitter/opt/sqlite/include
> >>>>> -I/opt/twitter/opt/readline/include -isystem/opt/twitter/include
> >>>>> -F/opt/twitter/Frameworks -arch x86_64 -arch i386 -pipe
> >>>>> -I/private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/include
> >>>>> -I/private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/include
> >>>>> -I/private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/include/mesos
> >>>>> -I/private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/src
> >>
> -I/private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/src/python/native/src/mesos/native
> >>
> -I/private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/3rdparty/libprocess/3rdparty/protobuf-2.5.0/src
> >>
> -I/System/Library/Frameworks/Python.framework/Versions/2.7/include/python2.7
> >>>>> -c src/mesos/native/proxy_scheduler.cpp -o
> >>>>> build/temp.macosx-10.9-intel-2.7/src/mesos/native/proxy_scheduler.o
> >>>>>
> >>>>> /usr/bin/clang++ -bundle -undefined dynamic_lookup -arch x86_64
-arch
> >>>> i386
> >>>>> -Wl,-F. -lsasl2 -lsvn_delta-1 -lsvn_subr-1 -lapr-1 -lcurl -lz -Os
-w
> >>>> -pipe
> >>>>> -march=native -mmacosx-version-min=10.9
> >>
> -I/Library/Java/JavaVirtualMachines/jdk1.7.0_60.jdk/Contents/Home/include
> >>
> -I/Library/Java/JavaVirtualMachines/jdk1.7.0_60.jdk/Contents/Home/include/darwin
> >>>>> -I/opt/twitter/opt/openssl/include -I/opt/twitter/opt/sqlite/include
> >>>>> -I/opt/twitter/opt/readline/include -isystem/opt/twitter/include
> >>>>> -F/opt/twitter/Frameworks
> >>
> build/temp.macosx-10.9-intel-2.7/src/mesos/native/mesos_executor_driver_impl.o
> >>
> build/temp.macosx-10.9-intel-2.7/src/mesos/native/mesos_scheduler_driver_impl.o
> >>>>> build/temp.macosx-10.9-intel-2.7/src/mesos/native/module.o
> >>>>> build/temp.macosx-10.9-intel-2.7/src/mesos/native/proxy_executor.o
> >>>>> build/temp.macosx-10.9-intel-2.7/src/mesos/native/proxy_scheduler.o
> >>
> /private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/src/.libs/libmesos_no_3rdparty.a
> >>
> /private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/3rdparty/libprocess/.libs/libprocess.a
> >>
> /private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/3rdparty/leveldb/libleveldb.a
> >>
> /private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/3rdparty/zookeeper-3.4.5/src/c/.libs/libzookeeper_mt.a
> >>
> /private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/3rdparty/libprocess/3rdparty/glog-0.3.3/.libs/libglog.a
> >>
> /private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/3rdparty/libprocess/3rdparty/protobuf-2.5.0/src/.libs/libprotobuf.a
> >>
> /private/tmp/mesos20150914-60557-1cy03t/mesos-0.24.0/3rdparty/libprocess/3rdparty/libev-4.15/.libs/libev.a
> >>>>> -o build/lib.macosx-10.9-intel-2.7/mesos/native/_mesos.so -lsasl2
> >>>>> -lsvn_delta-1 -lsvn_subr-1 -lapr-1 -lcurl -lz
> >>>>>
> >>>>> ld: library not found for -lsvn_delta-1
> >>>>>
> >>>>> clang: error: linker command failed with exit code 1 (use -v to
see
> >>>>> invocation)
> >>>>>
> >>>>> error: command '/usr/bin/clang++' failed with exit status 1
> >>
> >>
>



-- 
Best Regards,
Haosdent Huang

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message