mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexander Rojas" <alexan...@mesosphere.io>
Subject Re: Review Request 32163: Added a function which checks if a json object is contained within another.
Date Tue, 21 Apr 2015 08:58:23 GMT


> On April 21, 2015, 1:50 a.m., Marco Massenzio wrote:
> > 3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp, line 315
> > <https://reviews.apache.org/r/32163/diff/8/?file=935461#file935461line315>
> >
> >     while I appreciate being thorough, strictly speaking this should not be here:
you're actually unittesting `JSON::parse()` with this `CHECK`
> >     
> >     two downsides:
> >     
> >     1. your test code is more verbose (and less readable);
> >     2. you may have failures here that are entirely unrelated to `Contains` (causing
folks to go scratching their head)
> >      
> >     Also, I would add some variety to your tests:
> >     ```
> >     {"an_array_of_doubles": [1.0, -22.33, 99.876]}
> >     {"an_array_of_arrays": [[2, 3], [99, -1]]}
> >     {"an_array_of_objects":[{"foo": 1, "bar": 2, "values": [5, 8, -1]}
> >     ```

The array of objects existed before, but it is after the objects tests.


- Alexander


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/32163/#review80854
-----------------------------------------------------------


On April 20, 2015, 6:28 p.m., Alexander Rojas wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/32163/
> -----------------------------------------------------------
> 
> (Updated April 20, 2015, 6:28 p.m.)
> 
> 
> Review request for mesos, Benjamin Hindman, Bernd Mathiske, Joerg Schad, Marco Massenzio,
Niklas Nielsen, and Till Toenshoff.
> 
> 
> Bugs: MESOS-2510
>     https://issues.apache.org/jira/browse/MESOS-2510
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> Adds a function which allows to perform comparison tests on subsets of json blobs. i.e.
> 
> ```cpp
> JSON::Value expected = JSON::parse(
>     "{"
>     "  \"key\" : true"
> 	"}").get();
> 
> // Returned json:
> // {
> //   "uptime" : 45234.123,
> //   "key" : true
> // }
> JSON::Value actual = bar();
> 
> // I'm only interested on the "key" entry and ignore the rest.
> EXPECT_TRUE(contains(actual, expected));
> ```
> 
> Increasing readability for tests that include json.
> 
> For more information on the reason of why this patch is needed, please check the JIRA
entry.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/json.hpp 334c898906018be6e663f53815abbe047806b95c

>   3rdparty/libprocess/3rdparty/stout/tests/json_tests.cpp f60d1bbe60f2e2b6460c06bba98e8b85ebb6a3f9

> 
> Diff: https://reviews.apache.org/r/32163/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Alexander Rojas
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message