mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominic Hamon" <dha...@twopensource.com>
Subject Re: Review Request 31471: stout: Create IP and IPNetwork AF_INET abstraction.
Date Fri, 06 Mar 2015 18:29:30 GMT


> On March 6, 2015, 10:23 a.m., Jie Yu wrote:
> > 3rdparty/libprocess/3rdparty/stout/include/stout/ip.hpp, lines 268-270
> > <https://reviews.apache.org/r/31471/diff/7/?file=886045#file886045line268>
> >
> >     As we discussed offline, please change the name of this function to:
> >     ```
> >     static IPNetwork LOOPBACK_V4();
> >     ```
> >     
> >     , because you already have IP and Network in the class name, no need to mentioned
it again. Also, this is like a constant, so use all capital case.

use of capital case for methods that are like constants isn't something we do elsewhere in
the code-base, is it? I think this should be named as a method to be consistent (and to protect
against any future changes that make it much more complex than just a returned constant).


- Dominic


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/31471/#review75500
-----------------------------------------------------------


On March 5, 2015, 11:39 a.m., Evelina Dumitrescu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/31471/
> -----------------------------------------------------------
> 
> (Updated March 5, 2015, 11:39 a.m.)
> 
> 
> Review request for mesos, Benjamin Hindman, Dominic Hamon, Jie Yu, Joris Van Remoortere,
and Niklas Nielsen.
> 
> 
> Repository: mesos
> 
> 
> Description
> -------
> 
> see summary
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/3rdparty/stout/include/stout/ip.hpp 0cd7cb526a3a2514b3b54552253dfa8919e948d0

>   3rdparty/libprocess/3rdparty/stout/include/stout/net.hpp 9635bbc6f7dae1d75a780069fcc60fb706221053

>   3rdparty/libprocess/3rdparty/stout/tests/ip_tests.cpp fb98317a68986cb1228c584a8cd83b07737895a8

> 
> Diff: https://reviews.apache.org/r/31471/diff/
> 
> 
> Testing
> -------
> 
> 
> Thanks,
> 
> Evelina Dumitrescu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message