mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ben Mahler" <benjamin.mah...@gmail.com>
Subject Review Request 29989: Renamed MockAllocatorProcess to TestAllocatorProcess.
Date Fri, 16 Jan 2015 23:12:31 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/29989/
-----------------------------------------------------------

Review request for mesos and Vinod Kone.


Bugs: MESOS-2232
    https://issues.apache.org/jira/browse/MESOS-2232


Repository: mesos-git


Description
-------

Our naming of `MockComponent` generally means that the component is mocked version of the
interface. (e.g. MockAuthorizer).

Whereas, our naming of `TestComponent` generally means that we wrap an implementation in a
mocked interface, in order to set expectations while still having functionality implemented
(e.g. TestContainerizer).


Diffs
-----

  src/tests/master_allocator_tests.cpp 2430622d09c7ef1e020e2eb8f97444e7efc7c8ea 
  src/tests/mesos.hpp 591134bab31da0a1cc224e332666d05f320d0f87 
  src/tests/resource_offers_tests.cpp d098e7016ac0da7f1d629af099bb1b8fa66da839 
  src/tests/slave_recovery_tests.cpp 809822e63b05a21418cd9297c927d656d6fd871d 

Diff: https://reviews.apache.org/r/29989/diff/


Testing
-------

make check


Thanks,

Ben Mahler


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message