mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominic Hamon" <dha...@twopensource.com>
Subject Re: Review Request 20423: Moved validation visitors out of master.cpp.
Date Tue, 02 Dec 2014 18:53:00 GMT


> On Dec. 2, 2014, 10:07 a.m., Jie Yu wrote:
> > 3rdparty/libprocess/include/process/timeout.hpp, line 4
> > <https://reviews.apache.org/r/20423/diff/4/?file=731479#file731479line4>
> >
> >     Could you please split the patches? Is this just a cleanup, or it's necessary
for this patch?

rebase issue.


> On Dec. 2, 2014, 10:07 a.m., Jie Yu wrote:
> > src/Makefile.am, lines 274-277
> > <https://reviews.apache.org/r/20423/diff/4/?file=731480#file731480line274>
> >
> >     visitor is the pattern we use to check offers and tasks. How about calling them
task_checker.hpp and offer_checker.hpp?
> 
> Jie Yu wrote:
>     Could you please explain the reason why dropping this? At least, it should be offer_visitor.hpp
(similar to drf_sorter.hpp, etc.)

i'm naming the files after the classes within for discoverability purposes. are you suggesting
i rename the classes too?


- Dominic


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/20423/#review63552
-----------------------------------------------------------


On Dec. 2, 2014, 10:46 a.m., Dominic Hamon wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/20423/
> -----------------------------------------------------------
> 
> (Updated Dec. 2, 2014, 10:46 a.m.)
> 
> 
> Review request for mesos and Benjamin Hindman.
> 
> 
> Bugs: MESOS-1064
>     https://issues.apache.org/jira/browse/MESOS-1064
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> This is the first step toward being able to write independent unit tests for the validation
visitors.
> 
> 
> Diffs
> -----
> 
>   src/Makefile.am 86161fe7a8bdd86958d24adb74d434cd92d7dfb8 
>   src/master/master.cpp 8fcda4b9b5857f14cff8f6af2de31cca0208b88d 
>   src/master/offervisitor.hpp PRE-CREATION 
>   src/master/offervisitor.cpp PRE-CREATION 
>   src/master/taskinfovisitor.hpp PRE-CREATION 
>   src/master/taskinfovisitor.cpp PRE-CREATION 
> 
> Diff: https://reviews.apache.org/r/20423/diff/
> 
> 
> Testing
> -------
> 
> make check.
> ran Java test framework.
> 
> 
> Thanks,
> 
> Dominic Hamon
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message