mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ryan Thomas <r...@ryant.org>
Subject Re: Running Docker Tests
Date Wed, 15 Oct 2014 08:07:21 GMT
Thanks Tim, I'm not sure what I'm doing wrong here, as it complains about
the cpu group being mounted (and runs no tests).

$ sudo bin/mesos-tests.sh --gtest_filter="DockerTest" --verbose
Source directory: /vagrant
Build directory: /vagrant/build
-------------------------------------------------------------
We cannot run any cgroups tests that require mounting
hierarchies because you have the following hierarchies mounted:
/sys/fs/cgroup/cpu
We'll disable the CgroupsNoHierarchyTest test fixture for now.
-------------------------------------------------------------
Note: Google Test filter =
DockerTest-CgroupsNoHierarchyTest.ROOT_CGROUPS_NOHIERARCHY_MountUnmountHierarchy:SlaveCount/Registrar_BENCHMARK_Test.performance/0:SlaveCount/Registrar_BENCHMARK_Test.performance/1:SlaveCount/Registrar_BENCHMARK_Test.performance/2:SlaveCount/Registrar_BENCHMARK_Test.performance/3
[==========] Running 0 tests from 0 test cases.
[==========] 0 tests from 0 test cases ran. (0 ms total)
[  PASSED  ] 0 tests.

  YOU HAVE 6 DISABLED TESTS


Am I specifying the wrong filter field for just the docker tests?

Cheers,

Ryan

On 15 October 2014 18:25, Timothy Chen <tnachen@gmail.com> wrote:

> Hi Ryan,
>
> You need to enable cgroups, mount the cpu subsystem and run your tests
> under root to run the docker tests.
>
> Also you need to run on Linux with docker version at least 1.0+ with
> docker daemon running.
>
> The warning you saw for the CgroupsNoHierarchyTest is specifically for
> that set of tests, so ignore them while you try to run the docker
> tests.
>
> Tim
>
> On Tue, Oct 14, 2014 at 10:05 PM, Ryan Thomas <ryan@ryant.org> wrote:
> > Hi, I am trying to run the docker test-suite for some changes that I have
> > made, and I am encountering the following situation which I can't seem to
> > remedy.
> >
> > After doing a full make check, I attempt to run the tests like this:
> >
> > $ bin/mesos-tests.sh --gtest_filter="Docker" --verbose
> >
> > However, I get a warning about cgroups:
> >
> > We cannot run any cgroups tests that require mounting
> > hierarchies because you have the following hierarchies mounted:
> > /sys/fs/cgroup/blkio, /sys/fs/cgroup/cpu, /sys/fs/cgroup/cpuacct,
> > /sys/fs/cgroup/cpuset, /sys/fs/cgroup/devices, /sys/fs/cgroup/freezer,
> > /sys/fs/cgroup/hugetlb, /sys/fs/cgroup/memory, /sys/fs/cgroup/perf_event
> > We'll disable the CgroupsNoHierarchyTest test fixture for now.
> >
> > The issue is if I unmount the groups, I get the following issue:
> >
> > We cannot run any Docker tests because:
> > Failed to find a mounted cgroups hierarchy for the 'cpu' subsystem; you
> > probably need to mount cgroups manually!
> >
> >
> > Could someone please offer some guidance on getting the docker tests to
> run?
> >
> > Cheers,
> >
> > Ryan
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message