mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mesos ReviewBot" <...@mesos.apache.org>
Subject Re: Review Request 27413: Rename the Node class in Endpoint and replace the ip and port pairs from the UPID class and process namespace with this concept.
Date Fri, 31 Oct 2014 04:06:46 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/27413/#review59301
-----------------------------------------------------------


Bad patch!

Reviews applied: [27413]

Failed command: ./support/apply-review.sh -n -r 27413

Error:
 2014-10-31 04:06:28 URL:https://reviews.apache.org/r/27413/diff/raw/ [43451/43451] ->
"27413.patch" [1]
Successfully applied: Rename the Node class in Endpoint and replace the ip and port pairs
from the UPID class and process namespace with this concept.

The Node class abstracts the endpoint notion: it defines the association of the ip and port
for a connection. A node defines more the host(which can have multiple active endpoints).
At the moment, the Node class is used to keep a mapping from a socket to the ip & port
pair in the process namespace.
I want to propose to rename this class in Endpoint and also extend its use by replacing the
ip & port fields from the UPID class and process namespace with this type.


Review: https://reviews.apache.org/r/27413
Checking 22 files using filter --filter=-,+build/class,+build/deprecated,+build/endif_comment,+readability/todo,+readability/namespace,+runtime/vlog,+whitespace/blank_line,+whitespace/comma,+whitespace/end_of_line,+whitespace/ending_newline,+whitespace/forcolon,+whitespace/indent,+whitespace/line_length,+whitespace/operators,+whitespace/semicolon,+whitespace/tab,+whitespace/todo
Total errors found: 0
ERROR: Commit spanning multiple projects.

Please use separate commits for mesos, libprocess and stout.

Paths grouped by project:
mesos:
  src/common/protobuf_utils.cpp
  src/master/master.cpp
  src/sched/sched.cpp
  src/scheduler/scheduler.cpp
  src/slave/http.cpp
  src/slave/slave.cpp
  src/tests/files_tests.cpp
  src/tests/gc_tests.cpp
  src/tests/logging_tests.cpp
  src/tests/master_contender_detector_tests.cpp
  src/tests/master_tests.cpp
  src/tests/monitor_tests.cpp
libprocess:
  3rdparty/libprocess/include/Makefile.am
  3rdparty/libprocess/include/process/endpoint.hpp
  3rdparty/libprocess/include/process/node.hpp
  3rdparty/libprocess/include/process/pid.hpp
  3rdparty/libprocess/include/process/process.hpp
  3rdparty/libprocess/src/http.cpp
  3rdparty/libprocess/src/pid.cpp
  3rdparty/libprocess/src/process.cpp
  3rdparty/libprocess/src/tests/benchmarks.cpp
  3rdparty/libprocess/src/tests/http_tests.cpp
  3rdparty/libprocess/src/tests/metrics_tests.cpp
  3rdparty/libprocess/src/tests/process_tests.cpp
Failed to commit patch

- Mesos ReviewBot


On Oct. 31, 2014, 3:45 a.m., Evelina Dumitrescu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/27413/
> -----------------------------------------------------------
> 
> (Updated Oct. 31, 2014, 3:45 a.m.)
> 
> 
> Review request for mesos, Dominic Hamon and switched to 'mcypark'.
> 
> 
> Bugs: MESOS-2019
>     https://issues.apache.org/jira/browse/MESOS-2019
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> The Node class abstracts the endpoint notion: it defines the association of the ip and
port for a connection. A node defines more the host(which can have multiple active endpoints).
> At the moment, the Node class is used to keep a mapping from a socket to the ip &
port pair in the process namespace.
> I want to propose to rename this class in Endpoint and also extend its use by replacing
the ip & port fields from the UPID class and process namespace with this type.
> 
> 
> Diffs
> -----
> 
>   3rdparty/libprocess/include/Makefile.am 542ae1c39283087da6fef69be29c811ac35f00f4 
>   3rdparty/libprocess/include/process/endpoint.hpp PRE-CREATION 
>   3rdparty/libprocess/include/process/node.hpp 7a96894456683be60595a8f96f85df37947ff5b6

>   3rdparty/libprocess/include/process/pid.hpp 23453229c2a868a62b143416de33cf630268a64e

>   3rdparty/libprocess/include/process/process.hpp 81a1f7a3fece78bb7df1e86850572922c8704ea4

>   3rdparty/libprocess/src/http.cpp 4ef00d11de4ff4e7eb4e44aac204147799f85ac2 
>   3rdparty/libprocess/src/pid.cpp 20ff25c0959c247687955535f02e0397653af52a 
>   3rdparty/libprocess/src/process.cpp 85fb9958342f0bcdde322d9c55333126e6f86668 
>   3rdparty/libprocess/src/tests/benchmarks.cpp 3177a8ecac6adf8b52c3160587dc3a4fe2707d26

>   3rdparty/libprocess/src/tests/http_tests.cpp a1c3685c88d268c7ecdc2dad22608198dc0b295d

>   3rdparty/libprocess/src/tests/metrics_tests.cpp 33539e45bab8f79afa773a325465016f01fd3b75

>   3rdparty/libprocess/src/tests/process_tests.cpp b985fb77ea05fae5c0b144ea48814acc7bb5135b

>   src/common/protobuf_utils.cpp a9b65e328c4c62bff7fbf5633dda25d742d79019 
>   src/master/master.cpp 762d2ff6c168ac212f70b43275692a77496a7fcd 
>   src/sched/sched.cpp 0fb8c7bda75545389f8024489b3c76ae115111f4 
>   src/scheduler/scheduler.cpp fb88a3e029e97ba33eae5d50503be5ed9c9533e6 
>   src/slave/http.cpp 965d78c3e3ea2e3c922f62aabf6fc87c5cf2ab8d 
>   src/slave/slave.cpp 96fb5f7385b0762d46d8129f7e43207bd6311644 
>   src/tests/files_tests.cpp a696aa22d56b37ee70c6e64c81a849da6d436451 
>   src/tests/gc_tests.cpp f7747e2999cbd64ab0cd0321cca0021489dc3346 
>   src/tests/logging_tests.cpp 58e9b3399c3de28b1c5b3a8ec8fdf85b7a31c6d5 
>   src/tests/master_contender_detector_tests.cpp 8f7fb18f0ca985364565fc4cd50f113b1461fbe7

>   src/tests/master_tests.cpp 2e525749247626c05efb2f54a707599facb114b6 
>   src/tests/monitor_tests.cpp 4b950e14bd94cdfa21212268b56bebdc1200078d 
> 
> Diff: https://reviews.apache.org/r/27413/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Evelina Dumitrescu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message