mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Till Toenshoff" <toensh...@me.com>
Subject Re: Review Request 27122: Reorganized authentication implementation locations.
Date Thu, 30 Oct 2014 02:47:17 GMT


> On Oct. 28, 2014, 11:37 p.m., Kapil Arya wrote:
> > src/authentication/cram_md5/authenticator.hpp, lines 19-20
> > <https://reviews.apache.org/r/27122/diff/2/?file=733314#file733314line19>
> >
> >     s/CRAMMD5/AUTHENTICATION_CRAM_MD5/ ?
> 
> Till Toenshoff wrote:
>     I find the idea of reversing the specification and the base interface rather unusual
and it also would not fit our current scheme, e.g. "ISOLATOR" -> "MEM_ISOLATOR" / "SHARED_FILESYSTEM_ISOLATOR".
>     Adding an extra underscore on the other hand should be fine.
> 
> Kapil Arya wrote:
>     I actually mean "__AUTHENTICATION_CRAM_MD5_AUTHENTICATOR_HPP__" to replace the existing
one to allow the base directory name to be also part of the include guard.

Whoops, sry - should have seen that. Thanks for this suggestion.


- Till


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/27122/#review58910
-----------------------------------------------------------


On Oct. 30, 2014, 1:13 a.m., Till Toenshoff wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/27122/
> -----------------------------------------------------------
> 
> (Updated Oct. 30, 2014, 1:13 a.m.)
> 
> 
> Review request for mesos, Adam B and Vinod Kone.
> 
> 
> Bugs: MESOS-1893
>     https://issues.apache.org/jira/browse/MESOS-1893
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> For paving the way into further authentication mechanism implementations, the existing
is reorganized.
> 
> Move src/sasl to src/authentication/cram_md5, rename src/tests/sasl_tests.cpp to src/tests/cram_md5_authentication_tests.cpp.
> Adapt depending include paths.
> Rename specific test implementations from SASL to CRAMMD5Authentication.
> Rename sasl namespace to cram_md5 throughout all uses.
> Add missing license blob to auxprop.cpp.
> 
> 
> Diffs
> -----
> 
>   src/Makefile.am f177d87 
>   src/authentication/cram_md5/authenticatee.hpp PRE-CREATION 
>   src/authentication/cram_md5/authenticator.hpp PRE-CREATION 
>   src/authentication/cram_md5/auxprop.hpp PRE-CREATION 
>   src/authentication/cram_md5/auxprop.cpp PRE-CREATION 
>   src/master/master.hpp b1a2cd0 
>   src/master/master.cpp 762d2ff 
>   src/sasl/authenticatee.hpp ec2c841 
>   src/sasl/authenticator.hpp 6f4d3db 
>   src/sasl/auxprop.hpp 44e201b 
>   src/sasl/auxprop.cpp 6de1222 
>   src/sched/sched.cpp 0fb8c7b 
>   src/scheduler/scheduler.cpp fb88a3e 
>   src/slave/slave.hpp eb5de73 
>   src/slave/slave.cpp 96fb5f7 
>   src/tests/cram_md5_authentication_tests.cpp PRE-CREATION 
>   src/tests/sasl_tests.cpp 30556fa 
> 
> Diff: https://reviews.apache.org/r/27122/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Till Toenshoff
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message