mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mesos ReviewBot" <...@mesos.apache.org>
Subject Re: Review Request 26622: Command Executor is broken when used with shell=false
Date Fri, 24 Oct 2014 08:20:16 GMT

-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/26622/#review58254
-----------------------------------------------------------


Bad patch!

Reviews applied: [26622]

Failed command: ./support/apply-review.sh -n -r 26622

Error:
 --2014-10-24 08:20:08--  https://reviews.apache.org/r/26622/diff/raw/
Resolving reviews.apache.org (reviews.apache.org)... 140.211.11.74
Connecting to reviews.apache.org (reviews.apache.org)|140.211.11.74|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 6363 (6.2K) [text/x-patch]
Saving to: '26622.patch'

     0K ......                                                100%  171M=0s

2014-10-24 08:20:09 (171 MB/s) - '26622.patch' saved [6363/6363]

'fullname' was not found
'email' was not found
Successfully applied: Command Executor is broken when used with shell=false

Basically if you use "shell=false" with a non-empty argument list and the Command Executor
it is completely broken.

When we clone the env vars to fork "mesos-executor" all of the original cmd args are cloned
as well (unintentionally) due to some protocol-buffer merge shenanigans.

Don't pass task-related arguments to mesos-executor.

The description on the linked jira ticket goes into more detail.


Review: https://reviews.apache.org/r/26622
fatal: empty ident name (for <>) not allowed
Failed to commit patch

- Mesos ReviewBot


On Oct. 24, 2014, 2:04 a.m., R.B. Boyer wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/26622/
> -----------------------------------------------------------
> 
> (Updated Oct. 24, 2014, 2:04 a.m.)
> 
> 
> Review request for mesos, Benjamin Hindman, Jie Yu, and Timothy Chen.
> 
> 
> Bugs: MESOS-1873
>     https://issues.apache.org/jira/browse/MESOS-1873
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> Basically if you use "shell=false" with a non-empty argument list and the Command Executor
it is completely broken.
> 
> When we clone the env vars to fork "mesos-executor" all of the original cmd args are
cloned as well (unintentionally) due to some protocol-buffer merge shenanigans.
> 
> Don't pass task-related arguments to mesos-executor.
> 
> The description on the linked jira ticket goes into more detail.
> 
> 
> Diffs
> -----
> 
>   src/slave/slave.cpp 55e5264 
>   src/tests/slave_tests.cpp a1bd00c 
> 
> Diff: https://reviews.apache.org/r/26622/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> added new test "SlaveTest.GetExecutorInfo" verifying the explicit desired behavior.
> 
> 
> Thanks,
> 
> R.B. Boyer
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message