mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominic Hamon" <dha...@twopensource.com>
Subject Re: Review Request 22353: Refactored Master::launchTasks
Date Mon, 09 Jun 2014 17:50:10 GMT


> On June 7, 2014, 9:27 p.m., Yifan Gu wrote:
> > I did this because I found that if those offervalidation and taskvalidation part
can be reused in other stuffs like resizeTasks.
> > And I hope this can make the launchTasks more readable.
> > This is just my first trial to refactor this part. I am not sure if it's consistent
to the project's style, so I really need some help.
> > Any feedback is highly welcome! Thank you!

See also https://reviews.apache.org/r/20423/ which takes the *Visitor classes out of master
and into their own files for easier testing/reuse.


- Dominic


-----------------------------------------------------------
This is an automatically generated e-mail. To reply, visit:
https://reviews.apache.org/r/22353/#review45029
-----------------------------------------------------------


On June 7, 2014, 9:29 p.m., Yifan Gu wrote:
> 
> -----------------------------------------------------------
> This is an automatically generated e-mail. To reply, visit:
> https://reviews.apache.org/r/22353/
> -----------------------------------------------------------
> 
> (Updated June 7, 2014, 9:29 p.m.)
> 
> 
> Review request for mesos, Adam B, Benjamin Hindman, Niklas Nielsen, and Vinod Kone.
> 
> 
> Repository: mesos-git
> 
> 
> Description
> -------
> 
> Refactored on Master::launchTasks:
> Extracted the offer validation and task validation logic, so that other modules can reuse
the code.(e.g. resize tasks).
> Put valid tasks in a ready queue after validation.
> Modified on ExecutorInfoChecker to support above.
> Changed Master::launchTask's interface from (const TaskInfo&, const Framework*, const
Slave*) 
> to (const TaskInfo&, const FrameworkID&, const SlaveID&).
> 
> 
> Diffs
> -----
> 
>   src/master/master.hpp e244831 
>   src/master/master.cpp 89f426c 
> 
> Diff: https://reviews.apache.org/r/22353/diff/
> 
> 
> Testing
> -------
> 
> make check
> 
> 
> Thanks,
> 
> Yifan Gu
> 
>


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message