mesos-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Vinod Kone (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (MESOS-825) Querying Slave Status uses wrong host
Date Wed, 20 Nov 2013 18:22:36 GMT

    [ https://issues.apache.org/jira/browse/MESOS-825?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=13827932#comment-13827932
] 

Vinod Kone commented on MESOS-825:
----------------------------------

How do you start the slave?

We have added a new flag (--hostname) to slave that will let you set a routable host name
that will be used by the web ui. This is on our master branch (and 0.15.0-rc4) but not in
0.14.2.

> Querying Slave Status uses wrong host
> -------------------------------------
>
>                 Key: MESOS-825
>                 URL: https://issues.apache.org/jira/browse/MESOS-825
>             Project: Mesos
>          Issue Type: Bug
>          Components: webui
>    Affects Versions: 0.14.0, 0.14.2
>         Environment: Ubuntu 12.04, EC2, Vagrant
>            Reporter: Brian Hicks
>            Priority: Minor
>              Labels: newbie
>
> What I do:
>  - Go to master's "slaves" tab
>  - Select an individual slave to view
> What I expect:
>  - Slave status, logs, etc.
> What I get:
>  - Red flash message that says "Failed to get slave usage / state: [object Object]".
>  - When I inspect the requests from the Chrome dev tools, I see it's trying to request
the hostname of the node. E.G. on EC2, instead of ec2-n-n-n-n.us-west-1.amazonaws.com:5051,
it's requesting ip-n-n-n-n.us-west-1.compute.internal:5051. When I run in vagrant, it uses
the hostname. Substituting the public host in the URLs works fine.
> Other info:
>  - I'm running the mesosphere prepackaged distribution, but have also been able to reproduce
by running `mesos-master --cluster=batman --ip=192.168.1.104 --port=5050 --zk=zk://localhost:2181/mesos`
>  - This is consistent between AWS and Vagrant
> Is there anything else you need from me, or am I just running Mesos incorrectly?



--
This message was sent by Atlassian JIRA
(v6.1#6144)

Mime
View raw message