mesos-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: Mesos-Buildbot » autotools,clang,--verbose --enable-libevent --enable-ssl,GLOG_v=1 MESOS_VERBOSE=1,ubuntu:14.04,(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)&&(!qnode3)&&(!H23) #4263
Date Tue, 26 Sep 2017 18:41:46 GMT
See <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=autotools,COMPILER=clang,CONFIGURATION=--verbose%20--enable-libevent%20--enable-ssl,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)&&(!qnode3)&&(!H23)/4263/display/redirect?page=changes>

Changes:

[klueska] Added CLI utility function to verify addresses.

[klueska] Added 'master' key as an acceptable key in the CLI's config.toml.

[klueska] Added default configuration file for CLI tests.

[klueska] Added CLI utility function to get agent address.

[klueska] Added 'mesos task list' command to CLI.

------------------------------------------
Started by upstream project "Mesos-Buildbot" build number 4263
originally caused by:
 Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on H21 (couchdbtest ubuntu xenial) in workspace <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=autotools,COMPILER=clang,CONFIGURATION=--verbose%20--enable-libevent%20--enable-ssl,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)&&(!qnode3)&&(!H23)/ws/>
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository https://git-wip-us.apache.org/repos/asf/mesos.git
 > git init <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=autotools,COMPILER=clang,CONFIGURATION=--verbose%20--enable-libevent%20--enable-ssl,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)&&(!qnode3)&&(!H23)/ws/>
# timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/mesos.git
 > git --version # timeout=10
 > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/mesos.git +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/mesos.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/mesos.git # timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/mesos.git
 > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/mesos.git +refs/heads/*:refs/remotes/origin/*
Checking out Revision 3d4c1cec5ee655654e24c75509bda594c7980f05 (origin/master)
Commit message: "Added 'mesos task list' command to CLI."
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 3d4c1cec5ee655654e24c75509bda594c7980f05
 > git rev-list 1b23456aa28f0cf3e12666b5470fcc12e0ddfa34 # timeout=10
[e7e8016c] $ /bin/bash -xe /tmp/jenkins5985034873888918039.sh
+ '[' origin/master = origin/1.0.x ']'
+ ./support/jenkins/buildbot.sh
Requirement already satisfied: virtualenv in /home/jenkins/.local/lib/python2.7/site-packages
Total errors found: 0
************* Module setup
R:  1, 0: Similar lines in 2 files
==cli.tests.task:44
==cli.tests.tests:37
        master = Master()
        master.launch()

        agent = Agent()
        agent.launch()

        task = Task({"command": "sleep 1000"})
        task.launch()
 (duplicate-code)
Total errors found: 12
Checking 1207 C++ files
Virtualenv for python linter not detected ... building
Rebuilding virtualenv ...
Checking 25 Python files
Build step 'Execute shell' marked build as failure
Not sending mail to unregistered user songzihao1990@gmail.com
Not sending mail to unregistered user benjamin.hindman@gmail.com

Mime
View raw message