mesos-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: Mesos-Buildbot » cmake,clang,--verbose,GLOG_v=1 MESOS_VERBOSE=1,ubuntu:14.04,(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2) #4058
Date Wed, 02 Aug 2017 22:54:35 GMT
See <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=cmake,COMPILER=clang,CONFIGURATION=--verbose,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)/4058/display/redirect?page=changes>

Changes:

[gregorywmann] Enabled filtering of the 'GET_AGENTS' v1 API call.

[gregorywmann] Added full authz for non summarized fields of `/slaves` endpoint.

------------------------------------------
Started by upstream project "Mesos-Buildbot" build number 4058
originally caused by:
 Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on qnode3 (ubuntu) in workspace <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=cmake,COMPILER=clang,CONFIGURATION=--verbose,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)/ws/>
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository https://git-wip-us.apache.org/repos/asf/mesos.git
 > git init <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=cmake,COMPILER=clang,CONFIGURATION=--verbose,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)/ws/>
# timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/mesos.git
 > git --version # timeout=10
 > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/mesos.git +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/mesos.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/mesos.git # timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/mesos.git
 > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/mesos.git +refs/heads/*:refs/remotes/origin/*
Checking out Revision e87569b2ae3c7f8303ce146f882c340b4fdd5ca4 (origin/master)
Commit message: "Added full authz for non summarized fields of `/slaves` endpoint."
 > git config core.sparsecheckout # timeout=10
 > git checkout -f e87569b2ae3c7f8303ce146f882c340b4fdd5ca4
 > git rev-list 00290fffa8e2429da298201985a468c5b9eda546 # timeout=10
[855015bf] $ /bin/bash -xe /tmp/jenkins5012526266019435920.sh
+ '[' origin/master = origin/1.0.x ']'
+ ./support/jenkins/buildbot.sh
Collecting virtualenv
  Using cached virtualenv-15.1.0-py2.py3-none-any.whl
Installing collected packages: virtualenv
Successfully installed virtualenv-15.0.1
You are using pip version 8.1.1, however version 9.0.1 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
3rdparty/libprocess/src/semaphore.hpp:242:  Weird number of spaces at line-start.  Are you
using a 2-space indent?  [whitespace/indent] [3]
3rdparty/libprocess/src/semaphore.hpp:243:  Weird number of spaces at line-start.  Are you
using a 2-space indent?  [whitespace/indent] [3]
Total errors found: 1
Total errors found: 0
Checking 1189 C++ files
Virtualenv for python linter not detected ... building
Rebuilding virtualenv ...
Checking 21 Python files
Build step 'Execute shell' marked build as failure
Not sending mail to unregistered user gregorywmann@gmail.com

Mime
View raw message