mesos-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: Mesos-Buildbot » cmake,gcc,--verbose --enable-libevent --enable-ssl,GLOG_v=1 MESOS_VERBOSE=1,ubuntu:14.04,(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2) #4060
Date Thu, 03 Aug 2017 07:55:59 GMT
See <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=cmake,COMPILER=gcc,CONFIGURATION=--verbose%20--enable-libevent%20--enable-ssl,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)/4060/display/redirect?page=changes>

Changes:

[zhq527725] Introduced `--default_container_dns` agent flag.

[zhq527725] Passed default container DNS info to Docker executor.

[zhq527725] Set container DNS with `--default_container_dns` in Docker executor.

[zhq527725] Set container DNS with `--default_container_dns` in DockerContainerizer.

[zhq527725] Set container DNS with `--default_container_dns` in CNI isolator.

[zhq527725] Parsed DNS related info from the output of `docker inspect`.

[zhq527725] Added a test `DockerContainerizerTest.ROOT_DOCKER_DefaultDNS`.

[zhq527725] Added a test `DefaultContainerDNSCniTest.ROOT_VerifyDefaultDNS`.

[zhq527725] Added a test `DefaultContainerDNSFlagTest.ValidateFlag`.

------------------------------------------
Started by upstream project "Mesos-Buildbot" build number 4060
originally caused by:
 Started by an SCM change
[EnvInject] - Loading node environment variables.
Building remotely on ubuntu-eu3 (ubuntu xenial) in workspace <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=cmake,COMPILER=gcc,CONFIGURATION=--verbose%20--enable-libevent%20--enable-ssl,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)/ws/>
Wiping out workspace first.
Cloning the remote Git repository
Cloning repository https://git-wip-us.apache.org/repos/asf/mesos.git
 > git init <https://builds.apache.org/job/Mesos-Buildbot/BUILDTOOL=cmake,COMPILER=gcc,CONFIGURATION=--verbose%20--enable-libevent%20--enable-ssl,ENVIRONMENT=GLOG_v=1%20MESOS_VERBOSE=1,OS=ubuntu%3A14.04,label_exp=(ubuntu)&&(!ubuntu-us1)&&(!ubuntu-eu2)/ws/>
# timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/mesos.git
 > git --version # timeout=10
 > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/mesos.git +refs/heads/*:refs/remotes/origin/*
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/mesos.git # timeout=10
 > git config --add remote.origin.fetch +refs/heads/*:refs/remotes/origin/* # timeout=10
 > git config remote.origin.url https://git-wip-us.apache.org/repos/asf/mesos.git # timeout=10
Fetching upstream changes from https://git-wip-us.apache.org/repos/asf/mesos.git
 > git fetch --tags --progress https://git-wip-us.apache.org/repos/asf/mesos.git +refs/heads/*:refs/remotes/origin/*
Checking out Revision 01e5bc386c744aa5e9976935674639595557a760 (origin/master)
Commit message: "Added a test `DefaultContainerDNSFlagTest.ValidateFlag`."
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 01e5bc386c744aa5e9976935674639595557a760
 > git rev-list 1793f8f2a6e98757dba06d9d70d7bd3c03830cf0 # timeout=10
[6760a905] $ /bin/bash -xe /tmp/jenkins9088696731913924412.sh
+ '[' origin/master = origin/1.0.x ']'
+ ./support/jenkins/buildbot.sh
Requirement already satisfied: virtualenv in /home/jenkins/.local/lib/python2.7/site-packages
3rdparty/libprocess/src/semaphore.hpp:242:  Weird number of spaces at line-start.  Are you
using a 2-space indent?  [whitespace/indent] [3]
3rdparty/libprocess/src/semaphore.hpp:243:  Weird number of spaces at line-start.  Are you
using a 2-space indent?  [whitespace/indent] [3]
Total errors found: 1
Total errors found: 0
Checking 1189 C++ files
Virtualenv for python linter not detected ... building
Rebuilding virtualenv ...
Checking 21 Python files
Build step 'Execute shell' marked build as failure
Not sending mail to unregistered user zhq527725@gmail.com
Not sending mail to unregistered user songzihao1990@gmail.com
Not sending mail to unregistered user gregorywmann@gmail.com

Mime
View raw message