mesos-builds mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vinod Kone <vinodk...@apache.org>
Subject Re: Build failed in Jenkins: Mesos » clang,--verbose --enable-libevent --enable-ssl,GLOG_v=1 MESOS_VERBOSE=1,ubuntu:14.04,(docker||Hadoop)&&(!ubuntu-us1) #1893
Date Wed, 30 Mar 2016 02:02:30 GMT
Great to know you find the root cause!

Regarding http parser 1.x, I think we might want to keep support for it
because we allow people to link  to a custom http parser
(--with-http-parser configure option).

On Tue, Mar 29, 2016 at 6:57 PM, zhiwei <zhiweik@gmail.com> wrote:

> Hi Vond,
>
> I think I found the root cause, will fix this soon.
>
> Just want to ask do we still need to support http-parser 1.x?
>
> The code logic of decoder.hpp has many `#if !(HTTP_PARSER_VERSION_MAJOR
> >=2)` and I want to remove them to make the code clean.
>
> On Wed, Mar 30, 2016 at 9:53 AM, Vinod Kone <vinodkone@apache.org> wrote:
>
>> I'm going to disable the two offending tests for now.
>>
>> On Tue, Mar 29, 2016 at 6:01 PM, zhiwei <zhiweik@gmail.com> wrote:
>>
>>> For other patches, I enabled ssl and libevent and tested yesterday, all
>>> passed.
>>>
>>> On Wed, Mar 30, 2016 at 7:00 AM, Vinod Kone <vinodkone@apache.org>
>>> wrote:
>>>
>>>>
>>>> On Tue, Mar 29, 2016 at 3:00 PM, zhiwei <zhiweik@gmail.com> wrote:
>>>>
>>>>> sorry, I did not test with enable ssl and libevent. I will investigate
>>>>> this issue today.
>>>>>
>>>>
>>>> Thanks Zhiwei. Make sure you include SSL testing in all your 3rd party
>>>> upgrade patches.
>>>>
>>>
>>>
>>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message