maven-wagon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Kathryn Huxtable <kath...@kathrynhuxtable.org>
Subject Re: Does wagon-scm work with maven-scm-provider-gitexe?
Date Tue, 30 Mar 2010 16:29:00 GMT
Okay, updating the plexus utils has other issues in my project, but I'll figure them out. Reordering
the extensions did the trick for the extension versions. Thanks.

I've created a very simple project at http://github.com/khuxtable/test-project, which has
no source (or docs) just to test site deploy. So the files I'm deploying are all just generated
reports from the reporting element.

I have the following in my POM:

<distributionManagement>
  <site>
    <id>test-project-site</id>
    <url>scm:git:git+ssh://git@github.com/khuxtable/test-project.git</url>
    <!--<url>scm:svn:https://seaglass.googlecode.com/svn/test-project-site</url>-->
  </site>
</distributionManagement>
<scm>
  <connection>scm:git:git://github.com/khuxtable/test-project.git</connection>
  <developerConnection>scm:git:git+ssh://git@github.com/khuxtable/test-project.git</developerConnection>
  <url>http://github.com/khuxtable/test-project</url>
</scm>

I get the following error when I do "mvn site:deploy":

scm:git:git+ssh://github.com/khuxtable/test-project.git - Session: Opened  
Uploading: . to scm:git:git+ssh://github.com/khuxtable/test-project.git

[INFO] Executing: /bin/sh -c cd /Users/huxtable/Documents/workspace/test-project/. &&
git ls-files
[INFO] Working directory: /Users/huxtable/Documents/workspace/test-project/.
[INFO] Executing: /bin/sh -c cd /var/folders/M+/M+95phY6GfOYTLYCJKW4Bk+++TI/-Tmp- &&
git clone git+ssh//github.com/khuxtable/test-project.git/. /var/folders/M+/M+95phY6GfOYTLYCJKW4Bk+++TI/-Tmp-/wagon-scm472467110.checkout
[INFO] Working directory: /var/folders/M+/M+95phY6GfOYTLYCJKW4Bk+++TI/-Tmp-
 Transfer error: org.apache.maven.scm.ScmException: Unable to commit file. The git-clone command
failed. fatal: Could not switch to 'git+ssh//github.com/khuxtable/test-project.git': No such
file or directory

scm:git:git+ssh://github.com/khuxtable/test-project.git - Session: Disconnecting  
scm:git:git+ssh://github.com/khuxtable/test-project.git - Session: Disconnected
[INFO] ------------------------------------------------------------------------
[ERROR] BUILD ERROR
[INFO] ------------------------------------------------------------------------
[INFO] Error uploading site

It looks to me as if someone is munging the repo URL.

I'm using the same syntax for it that I use for the <developerConnection> element. Should
I be?

What I really want to do, of course, is to push to the gh-pages branch, but I don't see any
configuration to allow me to do that.

-K

On Mar 29, 2010, at 1:18 PM, Brett Porter wrote:

> 
> On 29/03/2010, at 1:29 PM, Kathryn Huxtable wrote:
> 
>> urls[1] = file:/Users/huxtable/.m2/repository/org/codehaus/plexus/plexus-utils/1.5.1/plexus-utils-1.5.1.jar
> 
> 
> It looks like the project is using an older version of this library than is needed (at
least 1.5.6). You should add the newer version to you extensions also. Re-ordering the extensions
so that SCM is listed first may also help.
> 
> - Brett
> 
> --
> Brett Porter
> brett@apache.org
> http://brettporter.wordpress.com/
> 
> 
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: wagon-users-unsubscribe@maven.apache.org
> For additional commands, e-mail: wagon-users-help@maven.apache.org
> 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message