maven-wagon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "droidin.net" <dr...@droidin.net>
Subject Re: wagon-scm: 409 when trying to deploy
Date Fri, 04 Sep 2009 15:12:39 GMT

Thanks Brett,

I  changed deploy URL to:
        <snapshotRepository>
            <uniqueVersion>false</uniqueVersion>
            <id>engtools_snapshots</id>
            <name>EngTools Maven Repository</name>
           
<url>scm:svn:http://continuum.td.foo.com/svn_repos/maven/snapshots</url>
        </snapshotRepository>

and now I get buncj of linkage errors (I cleared everything including local
maven repo)

[INFO] [install:install {execution: default-install}]
[INFO] Installing C:\foo\sources\PTE\pte-web\target\pte-web-1.0-SNAPSHOT.jar
to C:\Documents an
d
Settings\boo\.m2\repository\foo\engtools\pte\pte-web\1.0-SNAPSHOT\pte-web-1.0-SNAPSHOT.j
ar
[INFO] [deploy:deploy {execution: default-deploy}]
[INFO] Retrieving previous build number from engtools_snapshots
[FATAL ERROR] org.apache.maven.plugin.deploy.DeployMojo#execute() caused a
linkage error (java.lang.
AbstractMethodError) and may be out-of-date. Check the realms:
[FATAL ERROR] Plugin realm =
app0.child-container[org.apache.maven.plugins:maven-deploy-plugin:2.4]
urls[0] = file:/C:/Documents and
Settings/boo/.m2/repository/org/apache/maven/plugins/maven-dep
loy-plugin/2.4/maven-deploy-plugin-2.4.jar
urls[1] = file:/C:/Documents and
Settings/boo/.m2/repository/org/codehaus/plexus/plexus-utils/1
.1/plexus-utils-1.1.jar
[FATAL ERROR] Container realm = plexus.core
urls[0] = file:/C:/java/apache-maven-2.2.0/bin/../lib/maven-2.2.0-uber.jar
[INFO]
------------------------------------------------------------------------
[ERROR] FATAL ERROR
[INFO]
------------------------------------------------------------------------
[INFO]
org.apache.maven.scm.command.checkout.AbstractCheckOutCommand.executeCheckOutCommand(Lorg/apa
che/maven/scm/provider/ScmProviderRepository;Lorg/apache/maven/scm/ScmFileSet;Lorg/apache/maven/scm/
ScmVersion;)Lorg/apache/maven/scm/command/checkout/CheckOutScmResult;
[INFO]
------------------------------------------------------------------------
[INFO] Trace
java.lang.AbstractMethodError:
org.apache.maven.scm.command.checkout.AbstractCheckOutCommand.execute
CheckOutCommand(Lorg/apache/maven/scm/provider/ScmProviderRepository;Lorg/apache/maven/scm/ScmFileSe
t;Lorg/apache/maven/scm/ScmVersion;)Lorg/apache/maven/scm/command/checkout/CheckOutScmResult;
        at
org.apache.maven.scm.command.checkout.AbstractCheckOutCommand.executeCommand(AbstractChec
kOutCommand.java:49)
        at
org.apache.maven.scm.command.AbstractCommand.execute(AbstractCommand.java:58)
        at
org.apache.maven.scm.provider.svn.AbstractSvnScmProvider.executeCommand(AbstractSvnScmPro
vider.java:354)

brettporter wrote:
> 
> You are trying to deploy directly to the SVN repository which won't  
> work unless it as auto_version turned on (and then you will get lots  
> of revisions).
> 
> You probably need to change the URL to scm:svn:http:// instead of just  
> http://
> 
> - Brett
> 
> On 26/08/2009, at 8:20 AM, droidin.net wrote:
> 
>>
>> When running "mvn deploy" I end up with error below (sorry for the  
>> long
>> stacktrace). Just to mention - I had the same 409 error when using  
>> wagon-svn
>> from http://is.gd/2yton. Any suggestions?
>>
>> I have Pom with the following settings for wagon-scm
>>
>>    <build>
>>        <extensions>
>>            <extension>
>>                <groupId>org.apache.maven.wagon</groupId>
>>                <artifactId>wagon-scm</artifactId>
>>                <version>1.0-beta-6</version>
>>            </extension>
>>            <extension>
>>                <groupId>org.apache.maven.scm</groupId>
>>                <artifactId>maven-scm-manager-plexus</artifactId>
>>                <version>1.3-SNAPSHOT</version>
>>            </extension>
>>            <extension>
>>                <groupId>org.apache.maven.scm</groupId>
>>                <artifactId>maven-scm-provider-svnexe</artifactId>
>>                <version>1.3-SNAPSHOT</version>
>>            </extension>
>>        </extensions>
>>    </build>
>>
>> My settings.xml for the server I'm trying to deploy to
>>
>>    <server>
>>      <id>engtools_snapshot</id>
>>      <username>rs1860xx</username>
>>      <password>mystrongpassword</password>
>>      <filePermissions>664</filePermissions>
>>      <directoryPermissions>775</directoryPermissions>
>>    </server>
>>
>>
>> And the error:
>>
>> [DEBUG] Failed to transfer file:
>> http://continuum.td.foo.com/svn_repos/maven/snapshots/foo/engtools/pte/pte-web/1.0-SNAPSHOT/pte-web-1.0-SNAPSHOT.jar

>> .
>> Return code is: 409
>> org.apache.maven.wagon.TransferFailedException: Failed to transfer  
>> file:
>> http://continuum.td.foo.com/svn_repos/maven/snapshots/foo/engtools/pte/pte-web/1.0-SNAPSHOT/pte-web-1.0-SNAPSHOT.jar

>> .
>> Return code is: 409
>> 	at
>> org 
>> .apache 
>> .maven 
>> .wagon 
>> .shared 
>> .http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:368)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .wagon 
>> .shared 
>> .http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:280)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .artifact 
>> .manager.DefaultWagonManager.putRemoteFile(DefaultWagonManager.java: 
>> 262)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .artifact 
>> .manager.DefaultWagonManager.putArtifact(DefaultWagonManager.java:172)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .artifact 
>> .deployer 
>> .DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:107)
>> 	at  
>> org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:173)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java: 
>> 483)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java: 
>> 678)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor 
>> .executeGoalWithLifecycle(DefaultLifecycleExecutor.java:540)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java: 
>> 519)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor 
>> .executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor 
>> .executeTaskSegments(DefaultLifecycleExecutor.java:332)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
>> 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
>> 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
>> 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>> 	at  
>> org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java: 
>> 41)
>> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> 	at
>> sun 
>> .reflect 
>> .NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> 	at
>> sun 
>> .reflect 
>> .DelegatingMethodAccessorImpl 
>> .invoke(DelegatingMethodAccessorImpl.java:25)
>> 	at java.lang.reflect.Method.invoke(Method.java:597)
>> 	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java: 
>> 315)
>> 	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>> 	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java: 
>> 430)
>> 	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>> [INFO]
>> ------------------------------------------------------------------------
>> [ERROR] BUILD ERROR
>> [INFO]
>> ------------------------------------------------------------------------
>> [INFO] Error deploying artifact: Failed to transfer file:
>> http://continuum.td.foo.com/svn_repos/maven/snapshots/foo/engtools/pte/pte-web/1.0-SNAPSHOT/pte-web-1.0-SNAPSHOT.jar

>> .
>> Return code is: 409
>>
>> [INFO]
>> ------------------------------------------------------------------------
>> [DEBUG] Trace
>> org.apache.maven.lifecycle.LifecycleExecutionException: Error  
>> deploying
>> artifact: Failed to transfer file:
>> http://continuum.td.foo.com/svn_repos/maven/snapshots/foo/engtools/pte/pte-web/1.0-SNAPSHOT/pte-web-1.0-SNAPSHOT.jar

>> .
>> Return code is: 409
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java: 
>> 703)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor 
>> .executeGoalWithLifecycle(DefaultLifecycleExecutor.java:540)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java: 
>> 519)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor 
>> .executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor 
>> .executeTaskSegments(DefaultLifecycleExecutor.java:332)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
>> 	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
>> 	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
>> 	at org.apache.maven.cli.MavenCli.main(MavenCli.java:362)
>> 	at  
>> org.apache.maven.cli.compat.CompatibleMain.main(CompatibleMain.java: 
>> 41)
>> 	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
>> 	at
>> sun 
>> .reflect 
>> .NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
>> 	at
>> sun 
>> .reflect 
>> .DelegatingMethodAccessorImpl 
>> .invoke(DelegatingMethodAccessorImpl.java:25)
>> 	at java.lang.reflect.Method.invoke(Method.java:597)
>> 	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java: 
>> 315)
>> 	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
>> 	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java: 
>> 430)
>> 	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
>> Caused by: org.apache.maven.plugin.MojoExecutionException: Error  
>> deploying
>> artifact: Failed to transfer file:
>> http://continuum.td.foo.com/svn_repos/maven/snapshots/foo/engtools/pte/pte-web/1.0-SNAPSHOT/pte-web-1.0-SNAPSHOT.jar

>> .
>> Return code is: 409
>> 	at  
>> org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:195)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java: 
>> 483)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .lifecycle 
>> .DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java: 
>> 678)
>> 	... 17 more
>> Caused by:  
>> org.apache.maven.artifact.deployer.ArtifactDeploymentException:
>> Error deploying artifact: Failed to transfer file:
>> http://continuum.td.foo.com/svn_repos/maven/snapshots/foo/engtools/pte/pte-web/1.0-SNAPSHOT/pte-web-1.0-SNAPSHOT.jar

>> .
>> Return code is: 409
>> 	at
>> org 
>> .apache 
>> .maven 
>> .artifact 
>> .deployer 
>> .DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:121)
>> 	at  
>> org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:173)
>> 	... 19 more
>> Caused by: org.apache.maven.wagon.TransferFailedException: Failed to
>> transfer file:
>> http://continuum.td.foo.com/svn_repos/maven/snapshots/foo/engtools/pte/pte-web/1.0-SNAPSHOT/pte-web-1.0-SNAPSHOT.jar

>> .
>> Return code is: 409
>> 	at
>> org 
>> .apache 
>> .maven 
>> .wagon 
>> .shared 
>> .http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:368)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .wagon 
>> .shared 
>> .http.AbstractHttpClientWagon.put(AbstractHttpClientWagon.java:280)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .artifact 
>> .manager.DefaultWagonManager.putRemoteFile(DefaultWagonManager.java: 
>> 262)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .artifact 
>> .manager.DefaultWagonManager.putArtifact(DefaultWagonManager.java:172)
>> 	at
>> org 
>> .apache 
>> .maven 
>> .artifact 
>> .deployer 
>> .DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:107)
>> 	... 20 more
>> -- 
>> View this message in context:
>> http://www.nabble.com/wagon-scm%3A-409-when-trying-to-deploy-tp25143236p25143236.html
>> Sent from the Wagon - Users mailing list archive at Nabble.com.
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: wagon-users-unsubscribe@maven.apache.org
>> For additional commands, e-mail: wagon-users-help@maven.apache.org
>>
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: wagon-users-unsubscribe@maven.apache.org
> For additional commands, e-mail: wagon-users-help@maven.apache.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/wagon-scm%3A-409-when-trying-to-deploy-tp25143236p25296238.html
Sent from the Wagon - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: wagon-users-unsubscribe@maven.apache.org
For additional commands, e-mail: wagon-users-help@maven.apache.org


Mime
View raw message