maven-wagon-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antti Virtanen <antti.virta...@nsn.com>
Subject Wagon 1.0-beta-3 changes
Date Mon, 16 Jun 2008 14:33:33 GMT

Hello,

I've been playing around with HTTP Wagon a bit, mainly to handle recursive
file downloads from remote servers. When I tried the latest version (beta-3)
I came across few issues:
 * Empty file transfers seems to cause NPE:
 
     java.lang.NullPointerException
        at
org.apache.maven.wagon.LazyFileOutputStream.flush(LazyFileOutputStream.java:77)
        at
org.apache.maven.wagon.AbstractWagon.transfer(AbstractWagon.java:491)
        at
org.apache.maven.wagon.AbstractWagon.getTransfer(AbstractWagon.java:325)
        at
org.apache.maven.wagon.AbstractWagon.getTransfer(AbstractWagon.java:297)
        at
org.apache.maven.wagon.AbstractWagon.getTransfer(AbstractWagon.java:274)
        at
org.apache.maven.wagon.StreamWagon.getIfNewer(StreamWagon.java:97)
        at org.apache.maven.wagon.StreamWagon.get(StreamWagon.java:61)

 * HttpWagon.getFileList(String) doesn't seem to return anything when used
with empty string arg. Previously it used to return the list of files of the
base URL where it was connected.

I used previously beta-2 and both of the previously mentioned issues worked
fine there.

Thanks
-- 
View this message in context: http://www.nabble.com/Wagon-1.0-beta-3-changes-tp17865756p17865756.html
Sent from the Wagon - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: wagon-users-unsubscribe@maven.apache.org
For additional commands, e-mail: wagon-users-help@maven.apache.org


Mime
View raw message